Getting DynDNS and updates working on new install

My YunoHost server

Hardware: Raspberry Pi 4 at home
YunoHost version: 4.1.7.2
I have access to my server : Through SSH + through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hello everyone! I’m really excited to get this little server set up, and I think I’m close. But because of how I chose to set it up initially, it seems to have gotten into an odd state that I can’t get out of. Here’s what I did:

When I set it up, I gave it a subdomain of my actual domain as its maindomain. (home.mattgauger.com) and figured I would set up the DNS later.

It had some issues initially because it couldn’t create a cert for this, and because there was no cert, both metronome and mysql failed to start.

I logged in after setting the admin password, and tried to upgrade with apt (and in the web, but most things I’m trying from the CLI here, so that’s what I’ll go with.)

sudo apt install --fix-broken and sudo dpg --configure -a both fail because metronome is failing, because of the lack of cert. (And the system won’t update while it thinks apt is broken, so I can’t install apps – I would’ve been happy to sort out dyndns + certs later and just access things on my local network.)

“Ok, I said, let’s do what they recommended – let’s use a nohost.me subdomain.”

I went to go add one as a secondary domain, and it too failed. The output is not very helpful, but it shows LDAP failing at the end (?)

... output...
Error: Unable to delete domain mathias.noho.st: error during LDAP delete operation with: rdn='virtualdomain=mathias.noho.st,ou=domains' and exception {'matched': u'ou=domains,dc=yunohost,dc=org', 'desc': u'No such object'}

I tried to create domains from the web console, but now it thinks I’ve set up a dyndns and says I can only have one. There’s no command like yunohost dyndns remove as far as I can tell. Any attempt to add another dyndns domain says

Error: You have already subscribed to a DynDNS domain

etc.

I think at this point, since I haven’t made much actual progress in using the server, I might just flash the SD card back to the base install and start over, knowing that I should’ve picked a .nohost.me or similar domain first. Is there any way to recover from this, before I try that?

Thank you in advance,

Matt

Hello, and welcome!

It would have been nice to share the logs of your “initial issues”. My guess is the lack of DNS records, but without logs it’s hard to say.

Though running apt directly should not break anything, the recommended method is described in our Updating documentation.

Logs. Logs. Logs. I cannot fathom why suddenly your apt is broken.

We indeed recommend our free dynamic DNS system for beginners, though people with their own domains can make it work too if they setup their DNS records.

No, please, do not filter and share the full logs. It looks like you are quoting an error on the rollback after failure, not the actual error.

You can find a bit more information in our documentation: Nohost.me domains | Yunohost Documentation


Anyhow:

  1. You totally can use your own domain, but do not try to setup the certificates before setting up the DNS records and making sure they are spread worldwide (or at least to Let’s Encrypt servers).
  2. Flash the SD card again
  3. If you are OK with it, I can reset your mathias.noho.st domain so that you can use it with your new install. Ping me here or on our support chatroom (preferred, I get notifications from it).

If you have any issue, please share the full logs (we have a “Share with YunoPaste” button if you use the webadmin) and errors displayed onscreen.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.