Galène log file folder, TURN "negociation failed"

I am running galena videoconferencing on my videochat.**** server.
The app works well but after a few minutes it disconnects remote users with the error “negotiation failed”.
I need to find the log files but the /var/log/galene/galene.log is always empty.
Is there a conf file or .go file I need to activate the log or does it mean there are no errors in galene? I would really appreciate some help with this.Thanks for a great server distro!

just a quick question about the galena.log file which I found in /opt/yunohost/galena but it is empty.
Where do I have to tell galena to write to the log file,please?
Merci for your help

Galène logs should be accessible with YunoHost webadmin → Services → galene
and for coturn: webadmin → Services → coturn-galene

@Vanitarium Following the issue with Turn on Galène mailing list, you can try to install Galène from this branch.

sudo yunohost app install

This branch don’t install coturn but uses the one provided by Galène.

@ericg thank you… I have to try that today.
Do I need to completely uninstall galene first? Will that also remove Turn server?
By the way I have been discussing with Juliusz Chroboczek about this and he emailed me this explanantion for the “Negotiating failed” error:

And, indeed, the log that you sent indicates that you’ve got some
networking issues:

Aug 01 15:20:09 galene[516]: 2021/08/01 15:20:09 Relay test failed: timeout
Aug 01 15:20:09 galene[516]: 2021/08/01 15:20:09 Perhaps you didn’t configure a TURN server?

The sequence of events is as follows:

  1. the client starts a video by sending an offer;
  2. the server sends an answer and starts ICE candidate gathering;
  3. the client detects the failure after 30s or so and sends an ICE restart;
  4. the candidate gathering at the server isn’t done yet, hence the error.

There are two things here that shouldn’t happen if the network is
functioning: the candidate gathering shouldn’t take so long, and the
client shouldn’t be attempting to restart ICE. Both of these indicate
that there’s a firewall in the way and that no TURN server is accessible.

So, I am about to remove galene from my yuno server and because of your message, I shall try the no turn version of galene. If that fails or kills my server I shall abandon galene since I am NOT a developer or coder of any sort and feel at the edge of my knowledge with this!
Thanks for caring and helping!

OK I am reporting back:

  1. Uninstalled galene
  2. Rebooted server
  3. Installed galene-without-turn as by @ericg post
  4. Install went OK no errors reported
  5. Login to galene OK from my PC to yunoserver
  6. Run /relay-test command and it returned error due to timeout
  7. Login from iphone via phone network (not wifi): The server error negotiation failed appears almost instantly and iphone is not showing video on PC and vice versa

Log is here:

I am at the end of my knowledge…
NOTE: I have opened all the ports required by galene in server firewall and my modem.
Log is here:

If there is anymore info required your questions are welcome: I really want to become independent of by using galene!!

Some more testing info:
1.Negotiation error appears about 14-15 sec after activating video on iPhone using Safari
2. Connecting with my Tuxedo laptop via wifi (same LAN as server) works very well but relay-test fails by timeout

Galène own turn server is using port 1194. Is it open in you box? (just trying to guess…)

Yep it is open in firewall of yunohost server

Just mentioning this because in your logs the port 1194 doesn’t show as open…

I don’t know you setup but you may need to open the ports used by galène in your internet box.

Hi I opened all the ports shown in log on the internet modem box . Will post screenshots in a while for others to understand . Thank you merci for pointing this out to me!

Herewith the screenshot from modem

SUCCESS: the relay test now worked …
here is the screenshot

@ericg can we put this on the forum discussions? I had not realised it was a message between you and me… sorry et merci

1 Like

@ericg thank you very much for making this public… there is some useful information here for other users! And thanks for making galene available for yunohost!

@ericg just another question…
Is the branch being updated or is it dormant?
Any suggestions to go back to the new version with-turn?
Thanks again for helping

I am waiting for the version 0.4 to come to set the version “without Turn” as master branch and keep a version with “Turn installed alongside” Glène in another branch.
Galène will have to be removed and reinstalled.

Merci I shall wait for your reply when it happens …

I have just updated yunohost and galene (0.4) and the app has stopped working. ICE agent not working and the log mentions Turn server issue. Relay test failed.

It worked fine up until this update. Any ideas what is wrong?


Without context and logs not really

Are you behind a box, on a VPS. Are you ports open?
Have you read the README: GitHub - YunoHost-Apps/galene_ynh: Galène package for YunoHost

Maybe install from the branch without Turn?? It solved similar issue for me but cannot be updated via yunohost after that.