Funkwhale installation fails

My YunoHost server

Hardware: cloud hosted server
YunoHost version: 11.2.8
I have access to my server : Through SSH or through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: Funkwhale version = 1.3.4~ynh1

Description of my issue

Hello
Funkwhale won’t install. I’ve got this error on installation = “An error has occurred in the application installation script”, "django.db.utils.OperationalError: FATAL: Peer authentication failed for user “funkwhale”

Complete logs are here https://paste.yunohost.org/raw/muvanebajo

Thanks in advance!
David

Any ideas?

Could you please try to install the latest testing version of Funkwhale?
sudo yunohost app install https://github.com/YunoHost-Apps/funkwhale_ynh/tree/testing --debug

I have tried and have this error = error: An error occurred inside the app installation script
new logs are here for funkwhale testing debug: https://paste.yunohost.org/raw/hivuwedudo

Can you share the content of /etc/postgresql/13/main/pg_hba.conf?

pg_hba.conf = https://paste.yunohost.org/raw/epepegejof

It’s the same for me with the exception that the 3 last lines are commented.

# Allow replication connections from localhost, by a user with the
# replication privilege.
local   replication     all                                     peer
host    replication     all             127.0.0.1/32            md5
host    replication     all             ::1/128                 md5

are like that

# Allow replication connections from localhost, by a user with the
# replication privilege.
#local   replication     postgres                                peer
#host    replication     postgres        127.0.0.1/32            md5
#host    replication     postgres        ::1/128                 md5

Try to comment those lines and install Funkwhale after?
(I must admit I don’t know the concrete impacts of this :sweat_smile:)

I commented as describe and restart postgresgl service.
I still got error on installation.
New logs are here = https://paste.yunohost.org/raw/behufarumi

Did you restart postgresql after applying the changes and before installing Funkwhale?

I’ve got the same error with installation of few other application like tiny tiny rss …
Somthing looks wrong on postgresql configuration.
WARNING - psql: error: FATAL: Peer authentication failed for user “ttrss”, another log for example = https://paste.yunohost.org/raw/merozozise

yes I restarted the service.

Interesting!

Try maybe

yunohost tools regen-conf postgresql

regen-conf command ends successfully.
After restart potgresql service and try a new installation, the error remains.
logs = https://paste.yunohost.org/raw/viyayejere

@Tho
I 've just fix this! On my yunohost server I’ve got 2 version of postgresql. V13 and V11. It seems that funkwhale use V11. I had to edit /etc/postgresql/11/main/pg_hba.conf and replace peer by md5 like this.

# "local" is for Unix domain socket connections only
local   all             all                                     md5

Thank you so much for your support, that really help me to solve this general issue on my yunohost server.

Cheers!

1 Like

Thanks for your feedback!
I wonder why you had to version of postgresql: I only have version 13 and everything works fine.

But as it seems to work now, enjoy your server :partying_face:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.