Flarum - forum package

en
fr

#1

Hello all,

I’ve packaged Flarum, a forum software. It’s nice, modern, à la Discourse, without the need for docker (cf. this thread).

Sources are there : https://github.com/YunoHost-Apps/flarum_ynh

Enjoy ! :slight_smile:


#2

Flarum is still in beta, and this package even more. I wrote it to learn how to package… and, it works !

Improvements to be done :

Feel free to test it !


Application login by SSOwat or LDAP
#3

Package updated.

Fully works !


#4

Hi @TitusPiJean, thank you very much for this package - and by the way for the Flarum discovery! I like the without the need for docker and will try it as soon as possible…


#5

Hi, and thanks for this package :heart_eyes_cat:

  • Could you send (if you want) the ownership (on settings) of the package to YunoHost-Apps organization.
  • That way colaborators could easily works on same package .
  • I sent you a request to join YunoHost-Apps organization.
  • Then, when you think the package is publishable, could you send a pull request to add the package on community list?
  • That way your version will be displayed on community apps list

#6

Thanks for the initiative and the good work!

However I cannot manage to install the package. I tried from both the YunoHost UI or via command line. With --debug and --verbose options in command line, I end up with:

114469 DEBUG action [29007.1] ended after 114.336s 114469 DEBUG lock has been released 114469 ERROR Installation failed

I uploaded the full log here (zerobin.net).

Note that, prior to that, I had to manually create directory /var/www/.cache/composer and subdirectories to avoid warnings such as:

17305 WARNING Installing flarum/flarum (v0.1.0-beta.5) 17306 WARNING Cannot create cache directory /var/www/.cache/composer/files/, or directory is not writable. Proceeding without cache 17318 WARNING - Installing flarum/flarum (v0.1.0-beta.5) 18294 WARNING Downloading: 100% 18341 WARNING 18391 WARNING Created project in . 18438 WARNING Cannot create cache directory /var/www/.cache/composer/repo/https---packagist.org/, or directory is not writable. Proceeding without cache 18439 WARNING Cannot create cache directory /var/www/.cache/composer/files/, or directory is not writable. Proceeding without cache 18635 WARNING Loading composer repositories with package information 18717 WARNING Updating dependencies (including require-dev)
Thanks for your help.


#7

@jellium Thank you for trying the package !

I think I was not cautious enough and I did not correctly clean my server before testing the package. Therefore it did not yell at me as it did to you.

I’ve created this issue, and I’m currently working on patching the problem, hopefully.


#8

Updated. Can you test it @jellium ?

@Moul I would gladly send the package to YunoHost-Apps. Is it by forking it, or is there another way to do so ?


#9

You could send ownership on on setting of the repository.


#10

Pro-Tip : you shoul avoid working on package on your production server ! Try to use a developement environnement (by using https://github.com/yunohost/ynh-dev or other solution). By doing that you can test your package on a fresh & clean server.

Thanks for working on Flarum, this is a really valueable app ! Do you manage to get a working ldap connection for members ?


#11

Yeah, I’ve been lazy… It won’t happen again ! :smile: I will take time this weekend to setup such a dev environment.

Not yet ! I’m learning to code as I go, so I may need some time to handle PHP.
@opi, could you have a look to this issue ? I tried to implement your automatic postinstall solution, but I got a missing class error.


#12

Hi there,
The installation worked, the issue seems to be fixed!
Post-installation worked too, I can test the forum now (-:

Thanks.


#13

Updated : automatic post-installation is implemented.
Now your forum is fully functional as soon as installation is finished.

Next step, SSOWat and LDAP integration. So far it felt like tinkering, but I sense that it requires more knowledge than I have. So don’t hesitate to help !


Discourse package?
#14

Great Work. I’ve discover Flarum when I was searching for a software which can create a forum. I’ve tried to install manually but many errors appear. So this package is an opportunity for me and it works !
I’ve just a question about Flarum : Can Admin create users ? And how can admin do this ?
And is it normal that when a user signs in(after signing up), nothing appears (just the name of the forum) ?

Thanks.

frju365


#15

Hi @frju365, thank you for testing the package !

It seems that the feature to add users from the admin panel is not implemented yet. Here is the open issue about it. I’m learning about SSOwat, LDAP and HTTP auth to implement automatic user creation with YNH’s login : you can create a new user with an API call and an admin token. See here, but I’ve yet to find the correct syntax of such a call.

About your empty forum after signing up and signing in, can you take a screenshot ? That’s definitely weird. Can you check that you’re still in https ? What about signing out, refresh, or signin in with admin account ? Don’t hesitate to open an issue on github with such information, I will try to reproduce the issue.


#16

Hello TitusPiJean,
Thanks for your answer.
To answer your questions :

  • I’m still in https:// when I sign in as user.
  • Nothing appears :
  • When I sign in with my admin account, Flarum appears. And as guest too. Only if I’m a member(user) nothing appears.

Thanks.
frju365


#17

Hi @frju365, I cannot reproduce the issue.
Can you remove and install the package again ?
If you can run the installation by command line sudo yunohost app install https://github.com/YunoHost-Apps/flarum_ynh --verbose, I would like to see the logs (don’t forget to remove any password, notably at the beginning of the log).


#18

Hi

I’m trying to install flarum in ynh beta 2.5 and installation failed.

I’m doing :
sudo yunohost app install https://github.com/YunoHost-Apps/flarum_ynh --verbose

I just notice a strange warning (to me) :
+ sudo mkdir /var/www/flarum
+ sudo mv /tmp/flaruminstall/flarum /var/www/flarum/..
Warning: mv: cannot create directory ‘/var/www/flarum/../flarum’: No such file or directory

And at the end :
Error: Installation failed

But no explicit error message during install…

Any idea where I should have a look to find a reason ?

Thx


#19

@TitusPiJean, Sorry… I’m a bit late… (3 months)
I’ve reinstalled Flarum on a new installation and now it works fine. That was surely a problem which come from the settings of nginx.

Thanks.

@nimch, a issue is opened on github for your problem.
https://github.com/YunoHost-Apps/flarum_ynh/issues/14#issuecomment-272830702


#20

@frju365, thanks for your answer. Without being able to replicate your issue, I confess I had put it aside. I’m glad it was solved !

@nimch, I indeed opened an issue. I will look into it tonight. Can you confirm that everything is up-to-date on your server, with the latest beta for YNH ?