[Fixed] Ssh password is wrong after rebot

  • READ ME AND USE THIS TEMPLATE IF YOU WANT TO GET HELP ! You may ask your question in english or french, whichever is easiest for you… But please use one of the templates provided below :wink:
  • LISEZ-MOI ET UTILISEZ CE MODÈLE DE TOPIC SI VOUS SOUHAITEZ OBTENIR DE L’AIDE ! Vous pouvez poser votre question en anglais ou français, selon ce qui est le plus simple pour vous… Mais de préférence en utilisant l’un des deux modèles fournis ci-dessous :wink:

:uk:/:us: Message template (english)

The “support” category is meant to ask for help or troubleshooting related to installing or using YunoHost or its applications. It is not to ask assistance on general system administration, network administration or special use cases that goes beyond the scope of the project. If you wish to discuss more advanced use case, please post in the “Advanced Use Case” category.

Before posting, please :

My YunoHost server

Hardware: VPS bought online - oracle cloud free tier
YunoHost version: Can’t figure out coz can’t ssh. Installed a few hours ago using ```
curl https://install.yunohost.org | bash

**I have access to my server :** Through SSH but I can't ssh after I rebooted the server
**Are you in a special context or did you perform some particular tweaking on your YunoHost instance ?** : not really, but the vps was converted from ubuntu to debian and then to yunohost


### Description of my issue

So I rebooted my host for the first time after installing yunohost, and I could no longer ssh into the vps. At first I panicked a lot but then I managed to enable ssh from my user (not the admin) in the settings....
So I logged into the server as my user and did `su` to get root privileges (sudo is disabled on user accounts by default)
I'm trying to enable logging into admin account but It doesn't seem to be working.

ok so I had edited the /etc/passwd a bit bcoz it didn’t contain the “admin” user and I wished to change the login shell.
Removing it and restarting fixed the issue