[Feedback] After migration to strech, some service configuration are marked as "changed"

Note: I could not find a good title, feel free to change it if needed

After migrating to Stretch, I could not chat with XMPP anymore. After digging on the server with ssh, I ran the command regen-conf and I got surprises :

  1. Some services are marked as modified while I did not changed anything myself. Is it a known issue ?
  2. Will it an issue for the future and next upgrades?

So I made this post to share the experience and to get feedback about this behavior. Can it be bad for other people / users ?



After running the command yunohost service regen-conf, I got the following results



Affected services

  1. dnsmask
  2. fail2ban
  3. metronome
  4. mysql
  5. nslcd
  6. postfix

I will go through them one by one and try to fix the issues identified previously


I am not going to explain in details how the command regen-conf works, I will just show the help. Feel free to come back to it in order to understand what the options I will use latter are made for


  1. dnsmask

After following this post Erreur dnsmasq sur un serveur OVH Kimsufi, I was able to :

  • find that my server (kimsufi box) has a default software installed that interfere with dnsmask
  • stop bind9
  • fix dnsmask by running yunohost service regen-conf dnsmasq -f -d

I add to disable bind9 too so it does not come back on next reboot : systemctl disable bind9

Well, the message is still there so I might do something else “later” or with an other service.

  1. fail2ban

I did not modify the file by hand and the new file seemed fine so I ran the update

  1. metronome

I remember changing it myself in the past. Config file agrees with me. So I overwrite my changes

Now, it works again on my phone \o/

  1. mysql

I did not changed anything so I was surprised.
After having a look, the difference comes from the migration process, not a big deal.

  1. nslcd

I do not know what it does so I ran the update /o\

  1. postfix

I do not use the emails so I ran the update anyway /o\

Same process as above to regen the configuration

Conclusion

dnsmaq configuration cannot be regenerated. Otherwise, server seems to be clean now :slight_smile:

3 Likes