# Etherpad Lite package

**URL:** https://forum.yunohost.org/t/etherpad-lite-package/68
**Category:** Support apps
**Tags:** french, english
**Created:** [October 21, 2014, 12:34pm UTC](https://forum.yunohost.org/t/etherpad-lite-package/68 "2014-10-21T12:34:55Z")
**Posts on this page:** 6
**Page:** 2

<div class="post-metadata">

### Author: ![Maniack\_Crudelis](https://forum.yunohost.org/user_avatar/forum.yunohost.org/maniack_crudelis/32/13_2.png) [@Maniack\_Crudelis](https://forum.yunohost.org/u/Maniack_Crudelis)
#### Post date: [July 10, 2016, 11:32pm UTC](https://forum.yunohost.org/t/etherpad-lite-package/68/21 "2016-07-10T23:32:27Z")

</div>

Hello  
You can test your backup/restore script with [package\_check](https://github.com/YunoHost/package_check).

I try to use it on your package, but my VM is very lazy this evening…

But already, you have an error on public\_site argument. In the manifest, public\_site is not a boolean. In the install script, public\_site is treated as boolean value.  
So, your app is always private.

---

<div class="post-metadata">

### Author: ![Bachy](https://forum.yunohost.org/user_avatar/forum.yunohost.org/bachy/32/30_2.png) [@Bachy](https://forum.yunohost.org/u/Bachy)
#### Post date: [July 11, 2016, 7:13am UTC](https://forum.yunohost.org/t/etherpad-lite-package/68/22 "2016-07-11T07:13:55Z")

</div>

fixed, thanks

---

<div class="post-metadata">

### Author: ![kanhu](https://forum.yunohost.org/user_avatar/forum.yunohost.org/kanhu/32/3518_2.png) [@kanhu](https://forum.yunohost.org/u/kanhu)
#### Post date: [July 11, 2016, 7:47am UTC](https://forum.yunohost.org/t/etherpad-lite-package/68/23 "2016-07-11T07:47:19Z")

</div>

I get 502 error  
nginx log:  
`2016/07/11 XX:XX:XX [error] 19010#0: *23188 connect() failed (111: Connection refused) while connecting to upstream, client: XX.XXX.XX.X, server: domain.tld, request: "GET /pad/ HTTP/1.1", upstream: "http://XX.XXX.XX.X:9001/", host: "domain.tld", referrer: "https://domain.tld/yunohost/sso/"`

---

<div class="post-metadata">

### Author: ![Maniack\_Crudelis](https://forum.yunohost.org/user_avatar/forum.yunohost.org/maniack_crudelis/32/13_2.png) [@Maniack\_Crudelis](https://forum.yunohost.org/u/Maniack_Crudelis)
#### Post date: [July 11, 2016, 11:01am UTC](https://forum.yunohost.org/t/etherpad-lite-package/68/24 "2016-07-11T11:01:47Z")

</div>

With package\_check, i’ve got a 404 on sub\_dir install, and nginx failed to start.

The upgrade script have some issues,  
`./upgrade: ligne 48: =/etc/nginx/conf.d/sous.domain.tld.d/etherpadlite.conf: Aucun fichier ou dossier de ce type`  
and  
`cp: opérande de fichier cible manquant après « ../conf/nginx.conf-nosub »`

And restore script have many error:  
`Warning: yunohost.hook <lambda> - [5701.1] Impossible d'installer l'application à cet emplacement Error: yunohost cli - Impossible d'installer l'application à cet emplacement Warning: yunohost.hook <lambda> - [5701.1] Path not available: sous.domain.tld/ Error: yunohost.backup backup_restore - [5701.1] Impossible de restaurer l'application « etherpadlite » Warning: yunohost.hook <lambda> - [5701.1] ERROR 1008 (HY000) at line 1: Can't drop database 'etherpadlite'; database doesn't exist Warning: yunohost.hook <lambda> - [5701.1] ERROR 1396 (HY000) at line 1: Operation DROP USER failed for 'etherpadlite'@'localhost' Warning: yunohost.hook <lambda> - [5701.1] Failed to stop etherpadlite.service: Unit etherpadlite.service not loaded. Warning: yunohost.hook <lambda> - [5701.1] rm: impossible de supprimer « /etc/init.d/etherpadlite »: Aucun fichier ou dossier de ce type Warning: yunohost.backup backup_restore - [5701.1] etherpadlite n'a pas été supprimé correctement`

You may check the complete log [here](https://framadrop.org/r/MnQjP31AJW#ldlLO4nIcTTTag1GPsk2mdMnwb+ShFSsJP+PnmU+iWo=).

---

<div class="post-metadata">

### Author: ![Bachy](https://forum.yunohost.org/user_avatar/forum.yunohost.org/bachy/32/30_2.png) [@Bachy](https://forum.yunohost.org/u/Bachy)
#### Post date: [July 14, 2016, 9:29am UTC](https://forum.yunohost.org/t/etherpad-lite-package/68/25 "2016-07-14T09:29:26Z")

</div>

hi,  
thanks for feedbacks  
i had this nginx errors, but since i installed the package on three ynh instance without a probleme  
i think the error is coming from etherpad, not from nginx, etherpad may not be active (despite the service is up withour error message)  
I never used pkg\_check script, i’ll learn it soon and try to fix the errors

---

<div class="post-metadata">

### Author: ![Aleks](https://forum.yunohost.org/user_avatar/forum.yunohost.org/aleks/32/1704_2.png) [@Aleks](https://forum.yunohost.org/u/Aleks)
#### Post date: [January 18, 2023, 8:11pm UTC](https://forum.yunohost.org/t/etherpad-lite-package/68/26 "2023-01-18T20:11:16Z")

</div>



[Previous page](https://forum.yunohost.org/t/etherpad-lite-package/68.md?page=1)
