Error while migration to 11

My YunoHost server

Hardware: Old laptop or computer
YunoHost version:
I have access to my server : Through SSH / through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

i got an while migration process. log:

i tried:
dpkg --configure -a
sudo apt install --fix-broken
sudo apt-get install -f
sudo apt-get clean
sudo apt-get install initramfs-tools
sudo dpkg --configure -a --force-depends

all without ant success.
i got: ‘update-initramfs: failed for /boot/initrd.img-5.10.0-17-amd64 with 1.’


WARNING - gzip: stdout: No space left on device

You have no space left in /boot/ to add the new kernel …

But before you fix that issue, please share the output of df -h | grep boot so that we have a clear idea of how many free MB there’s left, so that I can tweak the treshold supposed to detect this in the migration code

Also once you’ve fixed that issue, please DO NOT run apt (dist-)upgrade yourself. Please ONLY re-run the migration. Too many people manually run apt (dist-)upgrade themselves and that fuck shits up and we end up having to spend hours fixing everything.

# df -h | grep boot
Filesystem                Size  Used   Avail  Use% Mounted on
/dev/sda1                232M  194M   23M  90%    /boot

you are right there is no space left in /boot/.
i removed all the unused kernel and applied the migration again, and it worked.

but for some reason it didn’t install the new 5.10.0-17 kernel, i still at 4.19.0-20.


Probably because you need to reboot. The kernel is like the floor in your house … usually when you change the floor, you first get out of the house :wink:


it didn’t help either, after reboot i tried apt update && apt upgrade

but i am still on

# uname -r
# ls -lah /boot/
total 46M
drwxr-xr-x  4 root root 1.0K Aug 18 17:32 .
drwxr-xr-x 19 root root 4.0K Aug 18 17:31 ..
-rw-r--r--  1 root root 202K Mar 17 21:48 config-4.19.0-20-amd64
drwxr-xr-x  5 root root 1.0K Aug 18 17:31 grub
-rw-r--r--  1 root root  37M Aug 18 17:32 initrd.img-4.19.0-20-amd64
drwx------  2 root root  12K Dec  6  2020 lost+found
-rw-r--r--  1 root root 3.3M Mar 17 21:48
-rw-r--r--  1 root root 5.1M Mar 17 21:48 vmlinuz-4.19.0-20-amd64

btw there is no migration / app / package pending to update.
should i install the kernel manually?


Mokay then let’s maybe dpkg --reconfigure initramfs-tools

i guess you meant

#  dpkg-reconfigure initramfs-tools
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.140) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-20-amd64

but still after that (and update & upgrade) i on 4.19.0-20-amd64 and no new kernel downloaded.

Uuuuugh well then it’s quite puzzling, I don’t get why in the first log you posted it was attempting to add kernel 5.x to the initramfs … Maybe let’s check dpkg --list | grep linux | grep image but sounds like somehow kernel 5.x disappeared, idk …

i know it is quite odd.

# dpkg --list | grep linux | grep image
ii  linux-base                            4.6                                                all          Linux image base package
rc  linux-image-4.19.0-13-amd64           4.19.160-2                                         amd64        Linux 4.19 for 64-bit PCs (signed)
rc  linux-image-4.19.0-14-amd64           4.19.171-2                                         amd64        Linux 4.19 for 64-bit PCs (signed)
rc  linux-image-4.19.0-16-amd64           4.19.181-1                                         amd64        Linux 4.19 for 64-bit PCs (signed)
rc  linux-image-4.19.0-17-amd64           4.19.194-3                                         amd64        Linux 4.19 for 64-bit PCs (signed)
rc  linux-image-4.19.0-18-amd64           4.19.208-1                                         amd64        Linux 4.19 for 64-bit PCs (signed)
ii  linux-image-4.19.0-20-amd64           4.19.235-1                                         amd64        Linux 4.19 for 64-bit PCs (signed)

What about apt search linux-image | grep linux-image ?

for what it’s worth, i remind you i deleted everything but the kernel i was used from /boot/, including 5.10

but i thought it should try install it again after i will fix the space problem

# apt search linux-image | grep linux-image 

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

linux-image-4.19.0-13-amd64/now 4.19.160-2 amd64 [residual-config]
linux-image-4.19.0-14-amd64/now 4.19.171-2 amd64 [residual-config]
linux-image-4.19.0-16-amd64/now 4.19.181-1 amd64 [residual-config]
linux-image-4.19.0-17-amd64/now 4.19.194-3 amd64 [residual-config]
linux-image-4.19.0-18-amd64/now 4.19.208-1 amd64 [residual-config]
linux-image-4.19.0-20-amd64/now 4.19.235-1 amd64 [installed,local]
linux-image-5.10.0-11-amd64/stable-security 5.10.92-2 amd64
linux-image-5.10.0-11-cloud-amd64/stable-security 5.10.92-2 amd64
linux-image-5.10.0-11-rt-amd64/stable-security 5.10.92-2 amd64
linux-image-5.10.0-12-amd64/stable-security 5.10.103-1 amd64
linux-image-5.10.0-12-amd64-dbg/stable-security 5.10.103-1 amd64
  Debug symbols for linux-image-5.10.0-12-amd64
linux-image-5.10.0-12-amd64-unsigned/stable-security 5.10.103-1 amd64
linux-image-5.10.0-12-cloud-amd64/stable-security 5.10.103-1 amd64
linux-image-5.10.0-12-cloud-amd64-dbg/stable-security 5.10.103-1 amd64
  Debug symbols for linux-image-5.10.0-12-cloud-amd64
linux-image-5.10.0-12-cloud-amd64-unsigned/stable-security 5.10.103-1 amd64
linux-image-5.10.0-12-rt-amd64/stable-security 5.10.103-1 amd64
linux-image-5.10.0-12-rt-amd64-dbg/stable-security 5.10.103-1 amd64
  Debug symbols for linux-image-5.10.0-12-rt-amd64
linux-image-5.10.0-12-rt-amd64-unsigned/stable-security 5.10.103-1 amd64
linux-image-5.10.0-13-amd64/stable 5.10.106-1 amd64
linux-image-5.10.0-13-amd64-dbg/stable 5.10.106-1 amd64
  Debug symbols for linux-image-5.10.0-13-amd64
linux-image-5.10.0-13-amd64-unsigned/stable 5.10.106-1 amd64
linux-image-5.10.0-13-cloud-amd64/stable 5.10.106-1 amd64
linux-image-5.10.0-13-cloud-amd64-dbg/stable 5.10.106-1 amd64
  Debug symbols for linux-image-5.10.0-13-cloud-amd64
linux-image-5.10.0-13-cloud-amd64-unsigned/stable 5.10.106-1 amd64
linux-image-5.10.0-13-rt-amd64/stable 5.10.106-1 amd64
linux-image-5.10.0-13-rt-amd64-dbg/stable 5.10.106-1 amd64
  Debug symbols for linux-image-5.10.0-13-rt-amd64
linux-image-5.10.0-13-rt-amd64-unsigned/stable 5.10.106-1 amd64
linux-image-5.10.0-14-amd64/stable-security 5.10.113-1 amd64
linux-image-5.10.0-14-amd64-dbg/stable-security 5.10.113-1 amd64
  Debug symbols for linux-image-5.10.0-14-amd64
linux-image-5.10.0-14-amd64-unsigned/stable-security 5.10.113-1 amd64
linux-image-5.10.0-14-cloud-amd64/stable-security 5.10.113-1 amd64
linux-image-5.10.0-14-cloud-amd64-dbg/stable-security 5.10.113-1 amd64
  Debug symbols for linux-image-5.10.0-14-cloud-amd64
linux-image-5.10.0-14-cloud-amd64-unsigned/stable-security 5.10.113-1 amd64
linux-image-5.10.0-14-rt-amd64/stable-security 5.10.113-1 amd64
linux-image-5.10.0-14-rt-amd64-dbg/stable-security 5.10.113-1 amd64
  Debug symbols for linux-image-5.10.0-14-rt-amd64
linux-image-5.10.0-14-rt-amd64-unsigned/stable-security 5.10.113-1 amd64
linux-image-5.10.0-15-amd64/stable-security 5.10.120-1 amd64
linux-image-5.10.0-15-amd64-dbg/stable-security 5.10.120-1 amd64
  Debug symbols for linux-image-5.10.0-15-amd64
linux-image-5.10.0-15-amd64-unsigned/stable-security 5.10.120-1 amd64
linux-image-5.10.0-15-cloud-amd64/stable-security 5.10.120-1 amd64
linux-image-5.10.0-15-cloud-amd64-dbg/stable-security 5.10.120-1 amd64
  Debug symbols for linux-image-5.10.0-15-cloud-amd64
linux-image-5.10.0-15-cloud-amd64-unsigned/stable-security 5.10.120-1 amd64
linux-image-5.10.0-15-rt-amd64/stable-security 5.10.120-1 amd64
linux-image-5.10.0-15-rt-amd64-dbg/stable-security 5.10.120-1 amd64
  Debug symbols for linux-image-5.10.0-15-rt-amd64
linux-image-5.10.0-15-rt-amd64-unsigned/stable-security 5.10.120-1 amd64
linux-image-5.10.0-16-amd64/stable-security 5.10.127-2 amd64
linux-image-5.10.0-16-amd64-dbg/stable-security 5.10.127-2 amd64
  Debug symbols for linux-image-5.10.0-16-amd64
linux-image-5.10.0-16-amd64-unsigned/stable-security 5.10.127-2 amd64
linux-image-5.10.0-16-cloud-amd64/stable-security 5.10.127-2 amd64
linux-image-5.10.0-16-cloud-amd64-dbg/stable-security 5.10.127-2 amd64
  Debug symbols for linux-image-5.10.0-16-cloud-amd64
linux-image-5.10.0-16-cloud-amd64-unsigned/stable-security 5.10.127-2 amd64
linux-image-5.10.0-16-rt-amd64/stable-security 5.10.127-2 amd64
linux-image-5.10.0-16-rt-amd64-dbg/stable-security 5.10.127-2 amd64
  Debug symbols for linux-image-5.10.0-16-rt-amd64
linux-image-5.10.0-16-rt-amd64-unsigned/stable-security 5.10.127-2 amd64
linux-image-5.10.0-17-amd64/stable-security 5.10.136-1 amd64
linux-image-5.10.0-17-amd64-dbg/stable-security 5.10.136-1 amd64
  Debug symbols for linux-image-5.10.0-17-amd64
linux-image-5.10.0-17-amd64-unsigned/stable-security 5.10.136-1 amd64
linux-image-5.10.0-17-cloud-amd64/stable-security 5.10.136-1 amd64
linux-image-5.10.0-17-cloud-amd64-dbg/stable-security 5.10.136-1 amd64
  Debug symbols for linux-image-5.10.0-17-cloud-amd64
linux-image-5.10.0-17-cloud-amd64-unsigned/stable-security 5.10.136-1 amd64
linux-image-5.10.0-17-rt-amd64/stable-security 5.10.136-1 amd64
linux-image-5.10.0-17-rt-amd64-dbg/stable-security 5.10.136-1 amd64
  Debug symbols for linux-image-5.10.0-17-rt-amd64
linux-image-5.10.0-17-rt-amd64-unsigned/stable-security 5.10.136-1 amd64
linux-image-5.10.0-8-amd64/stable-security 5.10.46-5 amd64
linux-image-5.10.0-8-cloud-amd64/stable-security 5.10.46-5 amd64
linux-image-5.10.0-8-rt-amd64/stable-security 5.10.46-5 amd64
linux-image-amd64/stable-security 5.10.136-1 amd64
linux-image-amd64-dbg/stable-security 5.10.136-1 amd64
linux-image-amd64-signed-template/stable-security 5.10.136-1 amd64
  Template for signed linux-image packages for amd64
linux-image-cloud-amd64/stable-security 5.10.136-1 amd64
linux-image-cloud-amd64-dbg/stable-security 5.10.136-1 amd64
linux-image-rt-amd64/stable-security 5.10.136-1 amd64
linux-image-rt-amd64-dbg/stable-security 5.10.136-1 amd64

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.