Error when updating apps with Moulinette

,

Hey,

I just tried yunohost app upgrade and got the following output:

Traceback (most recent call last):
  File "/usr/bin/yunohost", line 142, in <module>
    _init_moulinette()
  File "/usr/bin/yunohost", line 124, in _init_moulinette
    init(logging_config=logging, _from_source=IN_DEVEL)
  File "/usr/lib/python2.7/dist-packages/moulinette/__init__.py", line 59, in init
    configure_logging(logging_config)
  File "/usr/lib/python2.7/dist-packages/moulinette/utils/log.py", line 42, in configure_logging
    dictConfig(logging_config)
  File "/usr/lib/python2.7/logging/config.py", line 794, in dictConfig
    dictConfigClass(config).configure()
  File "/usr/lib/python2.7/logging/config.py", line 576, in configure
    '%r: %s' % (name, e))
ValueError: Unable to configure handler 'file': [Errno 13] Permission denied: '/var/log/yunohost/yunohost-cli.log'

Does someone have a tip on how to move forward?
Thnx!

1 Like

Hi,

Did you enter this with sudo ?

1 Like

For me, in root, when I do "yunohost app upgrade"
I’ve the message Erreur : dokuwiki nécessite une version plus récente de la moulinette
There’s actually a problem with the moulinette to update apps, a newer version is needed. A post has been already done about it. We need to wait :slight_smile:

no… that did it. Thnx!:relaxed: