Error during synchronization with rsync

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Hello everyone,

I try to synchronize 2 external hard drives with rsync. Some files succeed in transfer, but an error occurs for the same file:

rsync -av source dest
-> rsync: read errors mapping "/source/file.ext": Input/output error (5)

After this error my hard drives are disconnected (and not appear anymore with lsblk)

If I try to see the progression of the transfer, the error does not appear but the transfer stays at 49%.

rsync -avP source dest

If I use the compression during the transfer, it is not the same file that cause the error.

rsync -avz source dest

I tried to understand the origin of this error. I found potential explanation: disk defect. But I have no idea how fix this issue…

Can I have help please. Thank you very much.

Hello everyone

The problem is solved. The error comes from the power provided by the official raspberry plug. It provides 3A max, that is not enough to power 2 additional external hard drives and lead to disconnections.

Solution: Use a HUB power by an external source of electricity.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.