Erreur renouvellement certificat liée soi-disant au port 80

Mon serveur YunoHost

Matériel: VM proxmox sur mini-pc
Version de YunoHost: 4.0.8.2
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : Réinstallation à partir d’une sauvegarde

Description du problème

Le certificat Let’s encrypt ne se renouvelle pas automatiquement. Dans la Webadmin, il y a ce message:

AVERTISSEMENT : le certificat actuel est sur le point d’expirer ! Il ne sera PAS renouvelé automatiquement !
Et en CLI dans une session SSH:

 yunohost domain cert-renew
 Erreur : Le domaine mondomaine.ynh.fr ne semble pas être accessible via HTTP. Merci de vérifier la catégorie 'Web' dans le diagnostic pour plus d'informations. (Ou si vous savez ce que vous faites, utilisez '--no-checks' pour désactiver la vérification.)

En parallèle l’outil de diagnostique m’adresse régulièrement ce mail:

[ERROR] Le domaine mondomaine.ynh.fr est inaccessible en HTTP depuis l’extérieur.

  • Expiration du délai en essayant de contacter votre serveur de l’extérieur. Il semble être inaccessible. Vérifiez que vous transférez correctement le port 80, que Nginx est en cours d’exécution et qu’un pare-feu n’interfère pas.

Je relance alors le diagnostique de la webadmin, je n’ai pas cette erreur.

Le port 80 est bien redirigé vers la VM au niveau de la box, et celui-ci est bien ouvert dans le parefeu de Yunohost.
Question: Puis-je lancer la commande conseillée avec l’option ‘–no-checks’ sans risque?
Que puis-je vérifier de plus pour résoudre le problème de façon durable?

Oui, dans le pire des cas il n’arrivera juste pas à installer le certif mais dans l’absolu ça ne casse rien

De ce que j’en vois, c’est peut-être un faux-négatif dû au fait qu’au moment où le diagnostique automatique se passe, peut-être que le serveur de notre côté est trop chargé et n’arrive pas à suivre … en tout cas ce genre de soucis a été rapporté par d’autres personnes … Pas sur de quoi te proposer exactement, mais on va ptete faire des ajustements pour que la probabilité que ça arrive diminue …

Ceci dit je suis quand même surpris car cette erreur ne devrait survenir qu’une fois de temps en temps au pire, et devrait quand même avoir laissé de la marge au renouveleur de certificat pour faire le renouvellement…

Bonjour @Aleks,

J’ai donc lancé la commande avec l’option --no-checks et c’est bon le certificat est bien installé, le problème datait depuis 5 jours. En CLI la réponse “Erreur” est instantanée", il ne semble pas y avoir un temps d’attente pour la réponse (ou alors en milisecondes!)

Est-ce que la sollicitation de ma connexion pourrait intervenir dans le temps de réponse et aboutir à cette erreur? Je dis ça car je suis en ADSL et en ce moment elle est beaucoup plus sollicitée que d’habitude.

3 jours plus tard…
@Aleks, j’ai continué à avoir des mails du diagnostique après le renouvellement du certificat à raison de 2 par jour. J’ai changé hier A.M. les horaires dans /etc/cron.d/yunohost-diagnosis et je n’ai pas eu d’avertissement ni hier soir, ni aujourd’hui. Une surcharge du serveur de votre côté parait donc probable, cette tâche cron se lançant chez tous les utilisateurs Yunohost à la même heure, modulo l’étalement du au RANDOM.
Tout comme toi je suis étonné car d’une part ce comportement est récent chez moi, d’autre part je ne vois pas d’autres demandes en ce sens sur le forum :confused:

Je confirme le bug, je l’ai constaté sur plusieurs instances.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.