Erreur dnsmasq sur un serveur OVH Kimsufi

Hm ouaip, les lignes sont tronquées … je crois qu’il faudrait la refaire avec l’option -l à la fin :confused:

root@ns328884:~# service dnsmasq status
● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled)
Drop-In: /run/systemd/generator/dnsmasq.service.d
└─50-dnsmasq-$named.conf, 50-insserv.conf-$named.conf
Active: failed (Result: exit-code) since lun. 2017-08-07 15:08:06 CEST; 50min ago
Process: 13030 ExecStart=/etc/init.d/dnsmasq systemd-exec (code=exited, status=2)
Process: 13027 ExecStartPre=/usr/sbin/dnsmasq --test (code=exited, status=0/SUCCESS)

août 07 15:08:06 ns328884.ip-37-187-115.eu dnsmasq[13027]: dnsmasq: syntax check OK.
août 07 15:08:06 ns328884.ip-37-187-115.eu dnsmasq[13030]: dnsmasq: impossible de créer une socket d’écoute pour port 53 : Adress…tilisée
août 07 15:08:06 ns328884.ip-37-187-115.eu systemd[1]: dnsmasq.service: control process exited, code=exited status=2
août 07 15:08:06 ns328884.ip-37-187-115.eu systemd[1]: Failed to start dnsmasq - A lightweight DHCP and caching DNS server.
août 07 15:08:06 ns328884.ip-37-187-115.eu systemd[1]: Unit dnsmasq.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.
root@ns328884:~#

Okay, c’est bizarre on dirait que tu as déjà quelque chose qui tourne sur le port 53 … Est-ce que tu peux faire un netstat -tulpn | grep :53 | grep LISTEN ?

root@ns328884:~# netstat -tulpn | grep :53 | grep LISTEN
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 16724/named
tcp6 0 0 ::1:53 :::* LISTEN 16724/named
root@ns328884:~#

Ok, on dirait que tu as un serveur bind qui tourne déjà sur ta machine … Est-ce que c’est normal ? Tu es parti de quoi avant d’installer YunoHost ?

Je suis parti d’une réinstallation sur mon kimsufi et j’ai simplement fait une installation de yunohost en root c’est tout

Hm okay… Du coup je pense qu’il faut que tu fasses un service bind9 stop (ou peut-être juste bind). Ensuite, retente un yunohost service regen-conf dnsmasq

1 Like

ok je viens de faire:
root@ns328884:~# service bind9 stop
root@ns328884:~# yunohost service regen-conf dnsmasq
Succès ! La configuration a été mise à jour pour le service « dnsmasq »
dnsmasq:
applied:
/etc/resolv.dnsmasq.conf:
status: updated
pending:
root@ns328884:~#

Je ne comprends pas je n’ai pas installé de service bind est-ce lié à l’installation fourni par kimsufi?

2 Likes

Oui, j’imagine… Je sais pas trop pourquoi ils installent ca par défaut mais bon :confused:. En tout cas maintenant tout devrait marcher :smile: :tada: !

Pour l’instant en tapant:
https://www.monsite.xyz/yunohost/admin
ou
https://monIPv4/yunohost/admin
J’arrive à un message d’avertissement:

Échec de la connexion sécurisée

Hmoui, c’est peut-être du au fait que tu utilises un certificat auto-signé… Tu peux regader pour ajouter un certificat Let’s Encrypt ici https://yunohost.org/#/certmanager_fr (depuis la ligne de commande, ou bien de puis l’interface d’admin, à laquelle tu devrais pouvoir accéder si tu ajoutes une exception pour le certif autosigné)

Je viens de faire:

root@ns328884:~# yunohost domain cert-status
certificates:
domaine.tld:
CA_type: Self-signed
summary: WARNING
validity: 3649
J’ai donc bien des certificats auto-signé

Puis ensuite j’ai tapé

root@ns328884:~# yunohost domain cert-install
Erreur : Certificate installation for wendling.xyz failed !
Exception: [Errno 22] Aucun enregistrement DNS « A » n’a été trouvé pour wendling.xyz. De devez faire pointer votre nom de domaine vers votre machine pour être capable d’installer un certificat Let’s Encrypt ! (Si vous savez ce que vous faites, utilisez --no-checks pour désactiver ces contrôles)
root@ns328884:~#

Pourtant la seule configuration que j’ai effectuée est chez mon registrar bookmyname est justement en champ en A:

www 28800 A ipv4deMonServeurKimsufi

Et les dns par défaut son ceux de bookmyname:

nsa.bookmyname.com
nsb.bookmyname.com
nsc.bookmyname.com

Une idée?

L’enregistrement www 28800 A ipv4deMonServeurKimsufi corresponds à www.wendling.xyz, pas à wendling.xyz.

Du coup :

  • soit tu rajoutes un enregistrement DNS @ 28800 A ipv4deMonServeurKimsufi (qui corresponds à wendling.xyz)
  • soit tu configures ton Yunohost pour gérer le domaine www.wendling.xyz (avec yunohost domain add www.wendling.xyz)

(Mais dans tous les cas, si tu veux utiliser ton instance yunohost via le domaine wendling.xyz, il faudra configurer le DNS correspondant)

Merci pour votre aide
J’ai choisi l’option de configurer Yunohost pour gérer le domaine. Donc je viens de faire:

root@ns328884:~# yunohost domain add www.domaine.tld
Mot de passe d’administration :
Succès ! Installation avec succès d’un certificat auto-signé pour le domaine www.domaine.tld !
Succès ! La configuration a été mise à jour pour le service « nginx »
Succès ! La configuration a été mise à jour pour le service « dnsmasq »
Succès ! La configuration a été mise à jour pour le service « metronome »
Succès ! Le domaine a été créé
root@ns328884:~#

Il reste votre dernière ligne qui me pose problème:
Mais dans tous les cas, si tu veux utiliser ton instance yunohost via le domaine wendling.xyz, il faudra configurer le DNS correspondant
Cela consiste à quoi faire?

C.f. le premier bullet point de mon message précédent :

  • rajouter un enregistrement DNS @ 28800 A ipv4deMonServeurKimsufi (qui corresponds à wendling.xyz)

D’accord mais il faut que je copie:
@ 28800 A ipv4deMonServeurKimsufi
dans quel fichier yunahost?

C’est pas sur YunoHost, c’est dans la configuration de ton DNS sur le registrar (bookmyname)…

De la même facon que tu as mis un enregistrement

www 28800 A ipv4deMonServeurKimsufi

il te faut un enregistrement

@ 28800 A ipv4deMonServeurKimsufi

Ok merci pour tout, cela fonctionne. Faut-il envisager de compléter chez bookmyname l’enregistrement en s’inspirant de:
https://yunohost.org/#/dns_config_fr
Je vais pourvoir terminer le tutoriel ssh et yunohost à partir de windows 10 dont j’ai mis le lien sur un autre post. Je vais finaliser cela en installant docuwiki nextcloud et limeservice!

(Prière de ne pas marquer ma dernière réponse comme étant la réponse au thread … Le probleme initial était lié à dnsmasq, pas à ton conf DNS… La conf DNS c’était un autre problème)

bravo à tous les deux. On voit les experts à l’œuvre :slight_smile: