Erreur "bizarre" lors de la mise à jour

Bonjour, j’ai obtenu une erreur en voulant faire la mise à jour suivante :

Voici :

Le journal historisé contient :

2019-10-15 07:34:31,247: INFO - +Calculating upgrade…
2019-10-15 07:34:31,951: INFO - +The following packages will be upgraded:
2019-10-15 07:34:31,953: INFO - + libsmbclient libwbclient0 samba-common samba-libs smbclient sudo-ldap
2019-10-15 07:34:32,355: INFO - +6 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2019-10-15 07:34:32,357: INFO - +Need to get 6,265 kB of archives.
2019-10-15 07:34:32,359: INFO - +After this operation, 0 B of additional disk space will be used.
2019-10-15 07:34:32,361: INFO - +Get:1 http://mirrors.ircam.fr/pub/raspbian/raspbian stretch/main armhf libsmbclient armhf 2:4.5.16+dfsg-1+deb9u2 [144 kB]
2019-10-15 07:34:32,563: INFO - +Get:2 http://mirrors.ircam.fr/pub/raspbian/raspbian stretch/main armhf smbclient armhf 2:4.5.16+dfsg-1+deb9u2 [372 kB]
2019-10-15 07:34:32,866: INFO - +Get:3 http://distrib-coffee.ipsl.jussieu.fr/pub/linux/raspbian/raspbian stretch/main armhf samba-libs armhf 2:4.5.16+dfsg-1+deb9u2 [4,394 kB]
2019-10-15 07:34:33,170: INFO - +Get:5 http://mirrors.ircam.fr/pub/raspbian/raspbian stretch/main armhf samba-common all 2:4.5.16+dfsg-1+deb9u2 [174 kB]
2019-10-15 07:34:33,272: INFO - +Get:4 http://ftp.igh.cnrs.fr/pub/os/linux/raspbian/raspbian stretch/main armhf libwbclient0 armhf 2:4.5.16+dfsg-1+deb9u2 [121 kB]
2019-10-15 07:34:33,977: INFO - +Get:6 http://mirrors.fe.up.pt/raspbian/raspbian stretch/main armhf sudo-ldap armhf 1.8.19p1-2.1+deb9u1 [1,060 kB]
2019-10-15 07:34:41,405: INFO - +Preconfiguring packages …
2019-10-15 07:34:42,109: INFO - +Fetched 6,265 kB in 4s (1,333 kB/s)
2019-10-15 07:34:44,318: INFO - +(Reading database …
(Reading database … 5%
(Reading database … 10%
(Reading database … 15%
(Reading database … 20%
(Reading database … 25%
(Reading database … 30%
(Reading database … 35%
(Reading database … 40%
(Reading database … 45%
(Reading database … 50%
(Reading database … 55%
(Reading database … 60%
(Reading database … 65%
(Reading database … 70%
(Reading database … 75%
(Reading database … 80%
(Reading database … 85%
(Reading database … 90%
(Reading database … 95%
(Reading database … 100%
(Reading database … 65326 files and directories currently installed.)
2019-10-15 07:34:44,322: INFO - +Preparing to unpack …/0-libsmbclient_2%3a4.5.16+dfsg-1+deb9u2_armhf.deb …
2019-10-15 07:34:44,430: INFO - +Unpacking libsmbclient:armhf (2:4.5.16+dfsg-1+deb9u2) over (2:4.5.16+dfsg-1+deb9u1) …
2019-10-15 07:34:44,632: INFO - +Preparing to unpack …/1-smbclient_2%3a4.5.16+dfsg-1+deb9u2_armhf.deb …
2019-10-15 07:34:44,634: INFO - +Unpacking smbclient (2:4.5.16+dfsg-1+deb9u2) over (2:4.5.16+dfsg-1+deb9u1) …
2019-10-15 07:34:44,936: INFO - +Preparing to unpack …/2-samba-libs_2%3a4.5.16+dfsg-1+deb9u2_armhf.deb …
2019-10-15 07:34:45,039: INFO - +Unpacking samba-libs:armhf (2:4.5.16+dfsg-1+deb9u2) over (2:4.5.16+dfsg-1+deb9u1) …
2019-10-15 07:34:47,046: INFO - +Preparing to unpack …/3-libwbclient0_2%3a4.5.16+dfsg-1+deb9u2_armhf.deb …
2019-10-15 07:34:47,048: INFO - +Unpacking libwbclient0:armhf (2:4.5.16+dfsg-1+deb9u2) over (2:4.5.16+dfsg-1+deb9u1) …
2019-10-15 07:34:47,253: INFO - +Preparing to unpack …/4-samba-common_2%3a4.5.16+dfsg-1+deb9u2_all.deb …
2019-10-15 07:34:47,355: INFO - +Unpacking samba-common (2:4.5.16+dfsg-1+deb9u2) over (2:4.5.16+dfsg-1+deb9u1) …
2019-10-15 07:34:47,559: INFO - +Preparing to unpack …/5-sudo-ldap_1.8.19p1-2.1+deb9u1_armhf.deb …
2019-10-15 07:34:47,661: INFO - +Unpacking sudo-ldap (1.8.19p1-2.1+deb9u1) over (1.8.19p1-2.1) …
2019-10-15 07:34:49,275: INFO - +dpkg: error: dpkg status database is locked by another process
2019-10-15 07:34:50,682: WARNING - E: Sub-process /usr/bin/dpkg returned an error code (2)

J’en ensuite relancé la recherche de mises à jour, le webadmin m’annonce que le serveur est à jour.

Que dois-je comprendre ? Que dois-je faire ?

Merci ! :slight_smile:

Mon serveur YunoHost

Matériel: Raspberry Pi à la maison
Version de YunoHost: 3.6.5.2
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modifications particulières sur votre instance ? : non

Alors du coup de ce que je vois :

  • le gros message en rouge est un petit bug dans YunoHost qui a crashé en voulant t’informer que la mise à jour avait échoué (yep, un bug dans un bug)
  • La mise à jour semble avoir échouté à un moment à cause de +dpkg: error: dpkg status database is locked by another process … mais c’est étrange car c’est apt qui est censé gérer cette lock correctement …

Mais si tu dis que maintenant l’interface dis que le serveur est à jour, ça n’a pas l’air bien grave. Eventuellement pour voir si il y a des choses à remettre à plat, tu peux tenter un : dpkg --configure -a

La commande a renvoyé :

root@serveur:~# dpkg --configure -a
Setting up libwbclient0:armhf (2:4.5.16+dfsg-1+deb9u2) …
Setting up samba-libs:armhf (2:4.5.16+dfsg-1+deb9u2) …
Setting up samba-common (2:4.5.16+dfsg-1+deb9u2) …
Setting up libsmbclient:armhf (2:4.5.16+dfsg-1+deb9u2) …
Setting up smbclient (2:4.5.16+dfsg-1+deb9u2) …
Processing triggers for libc-bin (2.24-11+deb9u4) …
Processing triggers for systemd (232-25+deb9u12) …
Setting up sudo-ldap (1.8.19p1-2.1+deb9u1) …
Processing triggers for man-db (2.7.6.1-2) …

Donc a priori tout va bien ?
Merci pour ton aide !

Oui, mais il lui restait des choses à configurer comme décrit dans la sortie de la commande, sinon elle n’aurait rien affiché :wink:

Mais du coup c’est rentré dans l’ordre à priori!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.