Erreur : 502 Bad Gateway dans l'interface administrateur

Bonjour,

J’ai pu tester la nouvelle image pour raspberry 2 celle-ci fonctionne très bien (il ne faut pas oublier la manipulation concernant l’interface eth0/eth1). Pour information, j’avais pu en effet remarquer des instabillités sur l’ancienne version (pour raspberry 1) sur un raspberry 2 malgré mon précédent post.

Merci

J’ai un problème similaire sur un SheevaPlug

Le fichier d’erreur /var/log/nginx/jpbm.fr-error.log indique:

2015/07/15 21:27:19 [error] 20086#0: *17 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.0.10, server: jpbm.fr, request: “GET /yunohost/api/installed HTTP/1.1”, upstream: “http://127.0.0.1:6787/installed”, host: “jpbm.fr”, referrer: “https://jpbm.fr/yunohost/admin/

J’ai:

  1. changé le propriétaire du répertoire

    sudo chown -R www-data:www-data /var/www/yunohost/

  2. Ajouté au fichier yunohost_admin.conf

    listen 127.0.0.1;

  3. Redémarrer les services

    sudo service php5-fpm restart; sudo service nginx restart; sudo service yunohost-api restart

Et malheureusement, toujours l’erreur Erreur : 502 Bad Gateway dans l’interface administrateur
Merci pour votre aide

Toujours la même erreur :frowning: J’ai essayé sans succès:

sudo dpkg-reconfigure yunohost-admin
sudo dpkg-reconfigure yunohost-config
sudo dpkg-reconfigure moulinette-yunohost

mais aussi

sudo dpkg-reconfigure yunohost yunohost*
sudo service yunohost-api restart

Quelqu’un aurait-il le même soucis ?
Quelqu’un aurait-il une idée pour mieux cerner l’origine du problème ?

Hello,

Je viens de comprendre pourquoi j’avais l’erreur 502 chez moi depuis un bon moment, sur un SheevaPlug aussi.
En fait je me suis aperçu que yunohost-api faisait carrément un Segmentation fault et donc j’ai essayé tous les paramètres possibles pour arriver à la conclusion que c’est l’utilisation de web socket qui faisait planter le service.
Essaie de stopper le service:

sudo service yunohost-api stop

Lance ensuite le service manuellement avec l’option

yunohost-api --no-websocket

Essaie de te connecter sur l’interface web d’admin pour vérifier que ça fonctionne.
Si c’est OK, c’est le même problème. Tu peux donc mettre cette option par défaut dans /etc/init.d/yunohost-api

1 Like

Merci Massyas.
Cela résout le problème

Cool.
Dans ce cas, ne faudrait-il pas mettre ça dans la doc ou ouvrir un bug pour que ça puisse être corrigé d’une façon ou d’une autre?
Je pense que ce serait à mettre dans moulinette-yunohost https://github.com/YunoHost/moulinette-yunohost/

Même soucis sur une carte olimex (briqueinternet), en jessie, avec Yunohost en version testing

root@olinux: yunohost -v
moulinette: 2.3.0
yunohost: 2.3.0
yunohost-admin: 2.3.0

Merci @massyas pour le tip. @jerome, ça t’aide ?