Enregistrement TXT SPF de mon registrar

Mon serveur YunoHost

**Matériel : Brique Internet sans VPN, A20 Olinuxino Lime2, Armbian 23.8.1 Bullseye with Linux 6.1.53-current-sunxi
**Version de YunoHost : ** 11.2.5
J’ai accès à mon serveur : En SSH
Êtes-vous dans un contexte particulier ou avez-vous effectué des modifications particulières sur votre instance ? : non
**Mes applications ** : Dotclear2, Bludit, My_WebApp (x2), Nextcloud, Sogo, PhpmyAdmin, Converse, Webtrees
**Mes domaines ** : sante9naturel.fr, lesmegeresdelhumus.fr, fievrebleue.fr, webmail.lesmegeresdelhumus.fr
**Mes certs ** : Lets Encrypt

Bonjour,

Je n’ai pas trouvé de configuration de l’enregistrement TXT SPF qui ne génère pas une erreur du Diagnostic de la console web de YunoHost.

J’ai été obligé de modifié la configuration de cet enregistrement chez mon registrar GANDI car aucun des messages envoyés vers GMAIL.COM depuis mon domaine passait. Tout revenait en ‘Undelivered’ avec l’erreur suivante :

host gmail-smtp-in.l.google.com[172.253.62.26] said:
    550-5.7.26 This mail has been blocked because the sender is
    unauthenticated. 550-5.7.26 Gmail requires all senders to authenticate with
    either SPF or DKIM. 550-5.7.26  550-5.7.26  Authentication results:
    550-5.7.26  DKIM = did not pass 550-5.7.26  SPF [sante9naturel.fr] with ip:
    [212.27.42.2] = did not pass 550-5.7.26  550-5.7.26  To mitigate this
    issue, please visit Gmail's authentication guide 550-5.7.26 for
    instructions on setting up authentication: 550 5.7.26
    https://support.google.com/mail/answer/81126#authentication
    e12-20020ac8598c000000b00403be2ad0besi3450471qte.11 - gsmtp

J’ai donc modifié la configuration DNS de la façon suivante :

"v=spf1 mx a ip4:212.27.42.3/16 ~all"

Depuis les messages vers les serveurs de messagerie de google passent sans erreur.

Y-a-t-il une autre façon de faire qui ne génère pas d’erreur dans la console d’administration de YunoHost ?

Bien à vous,

Q

Tu confirmes que l’enregistrement recommandé par le diagnostic ne fonctionne pas ? Il s’agit de "v=spf1 a mx -all" .

Il me semble que déjà il faut mettre un tiret - et non une “vague” ~
"XXXX -all"

Perso j’héberge 2 noms de domaine chez gandi avec la valeur par défaut et pas de soucis

"v=spf1 a mx -all"

Sinon fais également un test avec https://www.mail-tester.com/
qui retourne généralement de bonnes pistes de résolution des soucis :wink:

Pour vérifier ton enregistrement spf

dig +short TXT nomDomaine.ext

1 Like

Bonjour et merci pour votre réponse @tituspijean,

L’enregistrement proposé par le diagnostic fonctionne.
Celui que j’ai modifié avec l’adresse ip4 d’un serveur STMP de Free fonctionne aussi MAIS il sort en erreur au niveau du diagnostic.

Bien à vous,

Q

Bonjour et merci pour votre réponse @crustyourmind,

C’est google qui n’accepte pas l’enregistrement de base proposé par YNH, soit "v=spf1 a mx -all". Dans ce cas, tous les messages envoyés aux adresses @gmail.com ne sont pas délivrés et le message qui m’est retourné indique que c’est l’enregistrement TXT SPF qui n’est pas valide.

D’où l’ajout d’une adresse ip4 d’un serveur SMTP de Free. Mais là c’est le diagnostic de YNH qui m’indique que l’enregistrement TXT SPF ne lui convient pas !

Bien à vous,

Q

Les résultats des tests avec mail-tester sont nickel chrome.

Je ne participe pas exactement au sujet, mais des infos malheureusement toujours à jour :
https://framablog.org/2017/02/17/etre-un-geant-du-mail-cest-faire-la-loi/
https://framablog.org/2018/08/09/fournisseurs-demails-arretez-de-faire-de-la-merde-pasmoncaca/

TL;DR : les mails, c’est pas compliqué, mais les gros font du n’importe quoi, parce qu’ils sont gros, et du coup, le mail c’est compliqué :sob:

Si sous free, le rDNS est alors configurable et les bugs ont été corrigés depuis peu
Ensuite oui, pour l’ipv6 pas de possibilité de rDNS donc ça retourne une erreur
Une solution est de ne garder le serveur de mail qu’en ipv4

Exemple du diagnostic


================================
Email (mail)
=================================

[ERROR] No reverse DNS is defined in IPv6. Some emails may fail to get delivered or be flagged as spam.
  - You should first try to configure reverse DNS with crust.ovh in your internet router interface or your hosting provider interface. (Some hosting providers may require you to send them a support ticket for this).
  - Some providers won't let you configure your reverse DNS (or their feature might be broken...). If your reverse DNS is correctly configured for IPv4, you can try disabling the use of IPv6 when sending emails by running 'yunohost settings set email.smtp.smtp_allow_ipv6 -v off'. Note: this last solution means that you won't be able to send or receive emails from the few IPv6-only servers out there.

Comme indiqué tu peux desactiver l’usage de lipv6 pour les mails… Ou simplement ignorer ce retour d’erreur …

Perso même avec cet avertissement j’ai 10/10 via mailtester en autohebergement avec un freebox mini4K. Donc ça doit passer (noms domaines chez ovh et chez gandi)

Il manquait le contexte de pourquoi tu avais modifié à la main l’enregistrement TXT SPF. :wink:

Tu fais donc appel à un relais SMTP pour faire sortir tes emails, et donc GMail exige un enregistrement TXT adapté.

Soit. Il te suffit simplement de cliquer sur “Ignorer” l’avertissement du Diagnostic.

Cet outil n’est pas omnipotent, il permet de se mettre en selle et de surveiller des dérives du serveur. Si tu sais ce que tu fais et que ça marche, tu peux ignorer ses avertissements.

Tout à fait d’accord, @crustyourmind. J’héberge également trois domaines avec GANDI comme registrar et tout allez bien tant que personne n’envoyait de messages sur GMAIL. Je ne rencontre ce problème d’enregistrement TXT SPF qu’avec GMAIL. Aucun autre serveurs de messagerie ne pose ce genre de problème. Pour contourner cela j’ai donc du ajouter dans l’enregistrement TXT SPF l’adresse IPv4 d’un serveur de messagerie de mon FAI. Pour ce qui est du rDNS en IPv6, oui j’avais bien compris le truc.

Non ce n’est pas un relais SMTP au sens strict. Je n’ai rien paramétré en ce sens dans YunoHost. J’ai essayé avec l’adresse IPv4 de mon serveur de messagerie mais les messages vers GMAIL ne partait toujours pas. J’ai donc trouvé cette astuce d’ajouter l’adresse IPv4 d’un serveur de messagerie FREE (puisque mon FAI est FREE) et depuis ça passe. GMAIL accepte les messages en provenance de mon serveur.
J’ai d’ailleurs cherché s’il y avait un paramétrage propre à ‘postfix’ sur YunoHost et je n’ai rien trouvé concernant l’envoie via SMTP des messages.
Ai-je loupé quelque chose ?

Bien à vous,

Q

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.