Email suddenly not being recieved

My YunoHost server

Hardware: VPS bought online / Old laptop or computer / Raspberry Pi (specify version, 0 to 4) at home / Internet Cube with VPN / Other ARM board / …
YunoHost version: 11.2.4
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no / yes
If yes, please explain:

Description of my issue

Hello everyone. Many thanks to all of those that bring YUNOHOST to us. It is very much appreciated.

I have been running my own email server for 12 months and it has never once been a problem. I have a fixed IP address and it has worked flawlessly, until last night…

I have 4 domains on my server, the main setup host is digitalcarnage.co.uk. When I started my own email server my ISP gave me reverse DNS to my hostname (digitalcarnage.co.uk) so the set up was complete and working. I do regular tests with all of the domains on all of the spam “stoppers” such as Spamhaus, Barracuda, abuseat and MXMAILTOOLS all of the major spam prevention services have given my email server 10/10 with no issues reported.

Suddenly I am not able to receive email, outgoing is fine. Two people alerted me to the problem and sent me the undeliverable report back for me to see on another non YUNOHOST email address that I have. both where using different providers but both had the same error message:

digitalcarnage gave this error:
Decision Engine classified the mail item was rejected because of IP Block (from outbound normal IP pools - 554 5.7.1 service unavailable; Client host [40.107.104.121] blocked using cal.abusesat.org; Error: open resolver; DNSBL Error Code - Open/public resolver - The Spamhaus Project

Again I checked in with all the major stopping sites and again no errors, another 10/10 my domain / IP address does not return any problems, so who, what and why am I no longer receiving email?

I am at a total loss on this one, for the moment I have changed the DNS settings with my registrar and all incoming mail is going to my iCloud account for all my domains as iCloud allow you to create domains. I have left one domain pointing to my YUNOHOST server to try and problem solve but I’m totally stuck.

The only thing I can say is that yesterday afternoon everything was working fine until YUNOHOST did a major php update (v7 & v8) I’m not sure what else was in that update, I’m no expert, but a php update shouldn’t effect email…? maybe, don’t know…

Can anyone help shed some light on this. I did see a similar issue here on the forum and the user just migrated to a VPS sighting the IP as being blocked for no mail being recieved, but my IP / domains are not being blocked and I don’t really want to migrate to a VPS as I have a perfectly good setup now, until now!!! Aggghhh!!!

I’d be grateful for any help with this issue.

Many thanks and have a great day

Dj

SOLVED:

Some time ago I changed the DNS settings in my router to point to Cloudflares 1.1.1.1 service which did work and has worked until last night when I could not receive email.

I found a link here on this forum saying that Spamhaus had changed their policy to stop using public DNS servers. (I will reference this post later) Sure enough when I changed the DNS settings in my router to my ISPs DNS servers… BANG! all good again.

A bit of a panic there for a while but solved.

So if you are experiencing the same issue, check your routers DNS server entries or just don’t use a public DNS service if you are hosting your own email server.

Many thanks

Dj

2 Likes

Can you please link the original post? I have temporarily mitigated the issue by commenting out reject_rbl_client zen.spamhaus.org, in /etc/postfix/main.cf

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.