Echec renouvellement certificat sur un sous-domaine hébergeant Collabora. Tous les autres se renouvellent

What type of hardware are you using: Old laptop or computer
What YunoHost version are you running: 12.1.40.1
How are you able to access your server: The webadmin
SSH
Direct access via physical keyboard/screen
Are you in a special context or did you perform specific tweaking on your YunoHost instance ?: Non

Describe your issue

Bonjour à tous,
Depuis 2 jours, j’ai un message CRON m’anoncant que mon sous.domaine documents.mondomaine.tld ne peut pas renouveler le certificat Let’s Encrypt.
Le renouvellement pour tous les autres sous-domainees - 4 avec applications (paheko 2 fois, roundcube, opensondages) + 2 sans application se renouvellent correctement.

Sur le domaine en question, Collabora 26 est installé et fontionne correctement.
Je pallie cette erreur en installant un certificat aut serveur DNS chez OVH ne rapporte aucune erreur particulière.

Share relevant logs or error messages

args:
force: true
no_checks: false
ended_at: 2026-08-19 15:01:24.364145
error: 'Certificate installation for documents.maindomain.tld failed !

Exception: Impossible de signer le nouveau certificat’
interface: api
operation: letsencrypt_cert_install
parent: null
related_to:

    • domain
    • documents.maindomain.tld
      started_at: 2026-08-19 15:01:16.981819
      started_by: ******
      success: false
      yunohost_version: 12.1.40.1

============

2026-08-19 17:01:18,002: DEBUG - Making sure tmp folders exists…
2026-08-19 17:01:18,015: DEBUG - Fetching IP from https://ipv4.yunohost.org
2026-08-19 17:01:18,165: DEBUG - IP fetched: xx.xx.xx.xx
2026-08-19 17:01:18,175: DEBUG - No default route for IPv6, so assuming there’s no IP address for that version
2026-08-19 17:01:18,175: DEBUG - IP fetched: None
2026-08-19 17:01:18,176: DEBUG - Prepare key and certificate signing request (CSR) for documents.maindomain.tld…
2026-08-19 17:01:20,862: DEBUG - Saving to /var/www/.well-known/acme-challenge-private/documents.maindomain.tld.csr.
2026-08-19 17:01:20,862: DEBUG - Now using ACME Tiny to sign the certificate…
2026-08-19 17:01:20,862: INFO - Parsing account key…
2026-08-19 17:01:20,873: INFO - Parsing CSR…
2026-08-19 17:01:20,883: INFO - Found domains: documents.maindomain.tld
2026-08-19 17:01:20,883: INFO - Getting directory…
2026-08-19 17:01:21,377: INFO - Directory found!
2026-08-19 17:01:21,377: INFO - Registering account…
2026-08-19 17:01:22,326: INFO - Already registered!
2026-08-19 17:01:22,327: INFO - Creating new order…
2026-08-19 17:01:23,369: INFO - Order created!
2026-08-19 17:01:24,346: INFO - Verifying documents.maindomain.tld…
2026-08-19 17:01:24,362: ERROR - Wrote file to /var/www/.well-known/acme-challenge-public/8SJ2D6x4EufNc6_x-ajTQKyUpQOgn79hNyCIBP4Z7TE, but couldn’t download http://documents.maindomain.tld/.well-known/acme-challenge/8SJ2D6x4EufNc6_x-ajTQKyUpQOgn79hNyCIBP4Z7TE: Error:
Url: http://documents.maindomain.tld/.well-known/acme-challenge/8SJ2D6x4EufNc6_x-ajTQKyUpQOgn79hNyCIBP4Z7TE
Data: None
Response Code: None
Response: <urlopen error [Errno 113] No route to host>
2026-08-19 17:01:24,363: ERROR - Certificate installation for documents.maindomain.tld failed !
Exception: Impossible de signer le nouveau certificat

Bonjour @yves.33.54

Que te renvoient

dig +short A documents.mondomaine.tld

dig +short A paheko.mondomaine.tld

?
La même ipv4 ?

Serait-il possible que documentsait un enregistrement AAAA alors que les autres ont un enregistrement A ?

Bonjour otm33,

J’avais consulté un autre post sur un sujet équivalent, et j’avais essayé ces 2 commandes.

Depuis une session serveur en SSH, les 2 me renvoient 127.0.0.1.

Depuis mon PC, les deux renvoient vers l’IPv4 du serveur.

Je n’ai pas configuré l’IPv6…

Bonne journée et merci de ton aide

Yves

En complément du message précédent, j’ai 2 entrées DNS OVH concernant Let’sEncrypt :

mondomaine.tld. 0 CAA 128 issue “letsencrypt.org ->Mon serveur
bdd.mondomaine.tld. 0 CAA 128 issue “letsencrypt.org” → Une des instances paheko

Je ne sais pas à quoi cela correspond (Je n’ai pas le souvenir des les avoir entrées).

Que renvoie curl -i http://documents.mondomaine.tld ?

Y a-t-il des erreurs dans le diagostic ?

As-tu essayé un force upgrade de l’application pour voir si cela changeait quelque chose ?

1 - Que renvoie curl -i http://documents.mondomaine.tld ?

HTTP/1.1 301 Moved Permanently
Server: nginx
Date: Thu, 20 Aug 2026 18:10:56 GMT
Content-Type: text/html
Content-Length: 162
Connection: keep-alive
Location: ``https://documents.mondomaine.tld

301 Moved Permanently

301 Moved Permanently


nginx

2 - Les diagnostics sont OK

Système de base Tout est OK !

Connectivité Internet Tout est OK !1 ignoré

Dernière exécution : il y a 1 minute

La résolution de nom de domaine fonctionne !

Le serveur est connecté à Internet en IPv4 !

Le serveur ne dispose pas d'une adresse IPv6.

Enregistrements DNS Tout est OK !

Exposition des ports Tout est OK !

Web Tout est OK !

Email Tout est OK !

État des services Tout est OK !

Ressources système Tout est OK !

Configurations système Tout est OK !

Applications Tout est OK !


3 - upgrade forcé ->Ok coolwsd.xml n’a pas été mis à jour (du fait des modifs pour prendre en compte le domaine paheko.mondomaine.tld, je suppose)

L’installation du certificat a échoué avec le même message d’erreur…

???

Yves

Et si tu essaies yunohost domain cert renew documents.mondomaine.tld --no-checks --force?

Entre temps, j’avais installé un certificat auto-signé, et la commande que tu as proposé me renvoie

:slight_smile: Erreur : Le certificat pour le domaine documents.mondomaine.tld n’est pas émis par Let’s Encrypt. Impossible de le renouveler automatiquement !

J’ai essayé : yunohost domain cert install documents.mondomaine.tld --no-checks --force

Yep - Le certificat s’est installé !

Mais pour vérifier que tout est bon, j’ai essayé de renouveler le certificat (avec --force seulement) et là patatras !

Avec --no-checks et --force, le certificat se renouvelle !!!

Ahh, je n’avais pas cette donnée… Rétrospectivement, je comprends que c’est dans cette phrase dont plusieurs mots sont coupés que tu parlais d’un certificat auto-signé.

Bonjour otm33

Désolé pour la confusion.

Ma situation aujourd’hui : Tous mes domaines et sous-domaines ont un certificat Let’s Encrypt valide et à jour.

Je pense attendre les 90 prochains jours pour le renouvellement automatique et voir ce qu’il se passe. Si la solution de renouvellement sans vérifs et forcée (–no-checks --force) fonctionne, je m’en contenterai.

A moins que tu n’aies d’autres propositions pour investiguer plus loin, on peut passer le sujet en résolu.

Merci de ton aide

Yves