Echec installation Home Assistant version python

Bonjour à tous,
Je rencontre un problème lors de l’installation de Home Assistant

Mon serveur YunoHost

Matériel: Raspberry Pi à la maison
Version de YunoHost: 3.6.5.3

Description du problème

l’installation de Home Assistant est annulée et m’indique l’erreur suivante :
homeassistant requires Python '>=3.6.1' but the running Python is 3.5.3

après vérification j’ai bien Python 3.5.3.

Savez vous quand yunohost va passer a une version de pyhton >= 3.6.1 ? ou y a il une autre solution pour installer Home Assistant ?

merci pour votre aide

Je sais pas pourquoi ce soucis arrive regulierement sur certaines apps mais c’est bizarre … Les tests racontent que l’app s’installe bien : https://dash.yunohost.org/appci/app/homeassistant

La version de Python est lié à Debian, donc tous les YunoHost en Stretch ont Python 3.5 (ce qui est aussi le cas pour nos tests automatiques)

Donc je ne sais pas pourquoi ça t’affiche ce message alors que les tests marchent, mais c’est pas la premiere fois que je vois ça arriver …

Well it sounds like @ewilly forgot to update the commit in the app catalog … I see that https://github.com/YunoHost-Apps/homeassistant_ynh/commit/ad00ca8a0d08334bec406611644ebeee5e87771a should fix the issue …

Can you try to install the app using the url of the repo directly ?

( @ewilly : can you consider updating https://github.com/YunoHost/apps/blob/master/apps.json ? (Maybe using HEAD to avoid that kind of issue :confused: ))

Hello,
Pull request done :slight_smile:

1 Like

yunohost app install https://github.com/YunoHost-Apps/homeassistant_ynh/commit/ad00ca8a0d08334bec406611644ebeee5e87771a
à résolu le problème

Merci pour votre aide :grinning:

1 Like