Dyndns with nohost.me not working anymore?

Hi,

I am running Yunohost 2.7.5 in a local VM on my virtualization server, and since 25th of December new IPs (I receive a new one every day) are not updated anymore at my XYZ.nohost.me subdomain.

I restarted the Yunohost VM, and from the command line I tried

yunohost dyndns update

but it terminates with an “communication with server failed …” error.

Is there a general problem with the nohost.me server or is it more likely a local problem with my Yunohost installation?

Thanks in advance and happy new year!

I have the same problem. yunohost dyndns update -d klimek.noho.st --verbose results in the following error message:

Updated needed, going on…
Now pushing new conf to DynDNS host…
Outgoing update query:
;; ->>HEADER<<- opcode: UPDATE, status: NOERROR, id: 0
;; flags:; ZONE: 0, PREREQ: 0, UPDATE: 0, ADDITIONAL: 0
;; ZONE SECTION:
;noho.st. IN SOA

;; UPDATE SECTION:
_xmpp-client._tcp.klimek.noho.st. 0 ANY ANY
_xmpp-server._tcp.klimek.noho.st. 0 ANY ANY
muc.klimek.noho.st. 0 ANY ANY
pubsub.klimek.noho.st. 0 ANY ANY
vjud.klimek.noho.st. 0 ANY ANY
klimek.noho.st. 0 ANY ANY
klimek.noho.st. 0 ANY ANY
mail._domainkey.klimek.noho.st. 0 ANY ANY
_dmarc.klimek.noho.st. 0 ANY ANY
klimek.noho.st. 0 ANY ANY
*.klimek.noho.st. 0 ANY ANY
klimek.noho.st. 0 ANY ANY
*.klimek.noho.st. 0 ANY ANY
_xmpp-client._tcp.klimek.noho.st. 3600 IN SRV 0 5 5222 klimek.noho.st.
_xmpp-server._tcp.klimek.noho.st. 3600 IN SRV 0 5 5269 klimek.noho.st.
muc.klimek.noho.st. 3600 IN CNAME klimek.noho.st.
pubsub.klimek.noho.st. 3600 IN CNAME klimek.noho.st.
vjud.klimek.noho.st. 3600 IN CNAME klimek.noho.st.
klimek.noho.st. 3600 IN MX 10 klimek.noho.st.
klimek.noho.st. 3600 IN TXT "v=spf1 a mx ip4:87.123.165.245 ip6:2001:16b8:282:300:3d72:74e9:83be:5c5a -all"
mail._domainkey.klimek.noho.st. 3600 IN TXT “v=DKIM1; k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDMQdb7x380iqD0jit+jZVqxbFYFRZK6SLNQ71QGOhe4rAaE6MZ3cjbLpHXP9hOEcweuF9b6pXuA3lb7qw5yXUAk+Sd5hmmR7Vzsw+jY9QxNN6U8+ezN3aqiCRKHyeAtM6g1RADgwb7ScFkWmpQDik0hKhzpcakf+za7eoBpmRlrwIDAQAB”
_dmarc.klimek.noho.st. 3600 IN TXT "v=DMARC1; p=none"
klimek.noho.st. 3600 IN A 87.123.165.245
*.klimek.noho.st. 3600 IN A 87.123.165.245
klimek.noho.st. 3600 IN AAAA 2001:16b8:282:300:3d72:74e9:83be:5c5a
*.klimek.noho.st. 3600 IN AAAA 2001:16b8:282:300:3d72:74e9:83be:5c5a

; Communication with server failed: operation canceled
Error: Unable to update IP address on DynDNS

I would really appreciate feedback on that matter.

Hm, I’m wondering if that could be an IPv6 issue since we’re having quite a hard time configuring it properly these days…

Can you do the following tests in ssh on your servers ?

> curl dyndns.yunohost.org     # Should show "Wanna play the Dynette?"

> host dyndns.yunohost.org     # I expect it to return some IPv6 address

Thank you for your answer.

curl dyndns.yunohost.org # Should show “Wanna play the Dynette?”

gives out the following html code (I removed some signs to not display it as formated text):

html>
head>301 Moved Permanently
body bgcolor=“white”>
center>h1>301 Moved Permanently
hr>nginx/1.10.3 (Ubuntu)
/body
/html>

host dyndns.yunohost.org # I expect it to return some IPv6 address

gives out the following:

dyndns.yunohost.org has address 91.224.148.92
dyndns.yunohost.org has IPv6 address 2a03:7220:8080:5c00::1

I hope this is helpful.

Ah sorry, that should be :

curl https://dyndns.yunohost.org 

Yes, with that command I get: Wanna play the dynette ?

Okay,

so one more thing, if you do :

cd tmp && wget https://dyndns.yunohost.org

somewhere you should see Connecting to dyndns.yunohost.org followed by an IP address. Do you see an IPv4 (91.224.148.92) or an IPv6 (2a03:7220:8080:5c00::1) ?

I get the same results …

I believe you forgot to put a / in front of tmp, so I altered that and the output is:

Code
cd /tmp && wget https://dyndns.yunohost.org
converted 'https://dyndns.yunohost.org' (ANSI_X3.4-1968) -> 'https://dyndns.yunohost.org' (UTF-8)
--2018-01-04 14:52:29--  https://dyndns.yunohost.org/
Resolving dyndns.yunohost.org (dyndns.yunohost.org)... 2a03:7220:8080:5c00::1, 91.224.148.92
Connecting to dyndns.yunohost.org (dyndns.yunohost.org)|2a03:7220:8080:5c00::1|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 24 [text/html]
Saving to: 'index.html'

index.html                100%[======================================>]      24  --.-KB/s   in 0s     

2018-01-04 14:52:29 (9.76 MB/s) - 'index.html' saved [24/24]

Indeed thanks. So I definitely think this is an IPv6 issue on our infra. We’re investigating / working on it. Thanks for reporting the issue !

All right. Thank you for that.

@lars @devor : is it working now ?

If no, could you try to run: /usr/bin/nsupdate -k /etc/yunohost/dyndns/*.private /etc/yunohost/dyndns/zone

1 Like

No, still not working.

If no, could you try to run: /usr/bin/nsupdate -k /etc/yunohost/dyndns/*.private /etc/yunohost/dyndns/zone

I tried and the machine gave this response:

incorrect section name: Private-key-format:
syntax error

Dear ljf,

many thanks, and yes it’s working again (dig A XYZ.nohost.me delivers the correct IP).

So I redid yunohost dyndns update -d klimek.noho.st --verbose and it was successful. But I still cannot reach my yunohost instance using that domain. Do I have to take more steps?

Update: It works now. Just had to wait some time. Thanks so much for your help!

This morning my Yunohost Server was not reachable again. After updating the dyndns with yunohost dyndns update -d klimek.noho.st --verbose it is working again at the moment. Is there a way to let Yunohost do that automatically again?

Yes, actually it should do it automatically every 2 minutes… There should be a cron job named /etc/cron.d/yunohost-dyndns (or something alike) that precisely does a yunohost dyndns update.

I’m not sure why you have a -d klimek.noho.st in your command line ? Does that work without it ?

I don’t actually know. I think I have the command from somewhere in this forum. yunohost dyndns update --verbose tells me No updated needed. I believe because I’ve already updated it today.
The content of /etc/cron.d/yunohost-dyndns is:

*/2 * * * * root yunohost dyndns update >> /dev/null

Is that correct?

Yup

Soooo really not sure why it’s not updating correctly :confused:

If you want to dig into my previous hypothesis, you can try to :

rm /etc/yunohost/dyndns/old_ip

then retry to update without the -d and see if that changes something…