DNS update error - no access to mydomain.nohost.me

, ,

Dear Yunohosters,

I woke up this morning and discovered my domain by defaut “mydomain.nohost.me” of my yunohost server was down.
After looking around I could figure it out that the update of the IP adress to DynDNS that occur during the night didn’t work.

I looked in the log and could found this error:

(Vous pouvez me répondre ne français ou en anglais, merci d’avance !)
(You can respond in French or English, thank you in advance !)

  domain: null
  dry_run: false
  dyn_host: dyndns.yunohost.org
  force: false
  ipv4: null
  ipv6: null
  key: null
ended_at: 2021-01-16 05:54:15.951675
error: Could not update IP address to DynDNS
interface: cli
operation: dyndns_update
parent: null
- - domain
  - maindomain.tld
started_at: 2021-01-16 05:53:12.925347
success: false


2021-01-16 06:53:12,952: INFO - Updated needed, going on...
2021-01-16 06:53:12,954: DEBUG - Reusing IPv4 from cache: xx.xx.xx.xx
2021-01-16 06:53:12,954: DEBUG - Reusing IPv6 from cache: None
2021-01-16 06:53:12,956: DEBUG - Now pushing new conf to DynDNS host...

Do you have any clue of what went wrong ?
How could I solve this problem to recover access to my server via my nohost.me domain ?

My YunoHost server

Hardware: VPS Hetzner
YunoHost version: 4.1.5 (stable) => I just update hopping the problem get solved… but no
I have access to my server : Through SSH or through the webadmin reached with my VPS IP adress
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

And I have received 200 messages during the last 9 hours “yunohost dyndns update” with an error message, maybe related? The domain is accessible, though:

Traceback (most recent call last):
  File "/usr/bin/yunohost", line 72, in <module>
  File "/usr/lib/moulinette/yunohost/__init__.py", line 29, in cli
  File "/usr/lib/python2.7/dist-packages/moulinette/__init__.py", line 120, in cli
    args, output_as=output_as, timeout=timeout
  File "/usr/lib/python2.7/dist-packages/moulinette/interfaces/cli.py", line 477, in run
    ret = self.actionsmap.process(args, timeout=timeout)
  File "/usr/lib/python2.7/dist-packages/moulinette/actionsmap.py", line 592, in process
    return func(**arguments)
  File "/usr/lib/moulinette/yunohost/log.py", line 358, in func_wrapper
    result = func(*args, **kwargs)
  File "/usr/lib/moulinette/yunohost/dyndns.py", line 219, in dyndns_update
    old_ipv4 = check_output("dig @%s +short %s" % (dyn_host, domain)) or None
  File "/usr/lib/python2.7/dist-packages/moulinette/utils/process.py", line 31, in check_output
    return subprocess.check_output(args, stderr=stderr, shell=shell, **kwargs).strip()
  File "/usr/lib/python2.7/subprocess.py", line 223, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command 'dig @dyndns.yunohost.org +short mydomain.nohost.me' returned non-zero exit status 9
1 Like

Can you try SSHing into your server and check if you can ping yunohost.org and dydns.yunohost.org

If you use Roundcube, you might have received a mail from Cron with an error log on the administration email. If you do not use Rounducbe, you can also check by cat /var/mail/admin_user/new/latest_file

Yes, that is the same error message I have been receiving too. The server might be under heavy load and is not able to process the requests. Only an admin can confirm about that issue.

same problem, with my ynh.fr domain!
I can ssh to my server (using the ip), but can’t access it with the domain name.

Same problem for my .noho.st domain. Yunohost DNS servers seem to be down. I also can’t ping dydns.yunohost.org, hostname can not be resolved.

i suppose the correct url should be dyndns.yunohost.org, not dydns!

cf. "dyndns.yunohost.org" at DuckDuckGo

Ok sorry, I copied it from navanchauhan’s message.I can ping dyndns.yunohost.org, but the dns problem persists.

c.f. Infrastructure is currently under DDOS - you may experience issues with various services - #3


The ynh.fr domain was not working from my computer with ipv4 enabled, but I could reach it from my phone with wifi and 4G. And on the compturer, after I’ve enabled ipv6, I could reach it again (my server is on the same local network).

It seems we’re experiencing something similar again today on nohost.me - this may be a result of yesterday’s troubles, or potentially something new?


Y a-t-il encore des soucis de ddos ? (J’ai encore des soucis d’update DNS.)

Command 'dig @dyndns.yunohost.org +short XXX.noho.st' returned non-zero exit status 9

On my side my problem is solved… everthing work again as normal.

Ok, alors le souci dois venir de mon coté car j’ai toujours le message d’erreur …

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.