Discourse installation echoué

bonsoir a tous, voila j essaye d’installer discourse sauf que j ai des messages d erreurs, j ai chercher sur le forum mais ne trouve pas mon erreur pour resoudre le probleme. merci par avance.
ci joint les log d’erreur.
https://paste.yunohost.org/raw/yahepubeko

Est-ce que tu peux faire un sudo pg_lsclusters (via SSH)

voila @Aleks
root@debian:~# sudo pg_lsclusters
Ver Cluster Port Status Owner Data directory Log file
root@debian:~#

Eh wokay, … let’s look at postgresql’s status then …

systemctl start postgresql

then

systemctl status postgresql

and

systemctl status postgresql@11-main

voici

● postgresql.service - PostgreSQL RDBMS
Loaded: loaded (/lib/systemd/system/postgresql.service; enabled; vendor prese
Active: active (exited) since Fri 2020-11-20 21:41:53 CET; 6min ago
Process: 14128 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
Main PID: 14128 (code=exited, status=0/SUCCESS)

nov. 20 21:41:53 game.autonomieclefutur.org systemd[1]: Starting PostgreSQL RDBM
nov. 20 21:41:53 game.autonomieclefutur.org systemd[1]: Started PostgreSQL RDBMS

root@game:~# systemctl status postgresql@11-main
● postgresql@11-main.service - PostgreSQL Cluster 11-main
Loaded: loaded (/lib/systemd/system/postgresql@.service; disabled; vendor pre
Active: inactive (dead)
lines 1-3/3 (END)
● postgresql@11-main.service - PostgreSQL Cluster 11-main
Loaded: loaded (/lib/systemd/system/postgresql@.service; disabled; vendor preset: enabled)
Active: inactive (dead)

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = “en_US.UTF-8”,
LANG = “fr_FR.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to a fallback locale (“fr_FR.UTF-8”).
Ver Cluster Port Status Owner Data directory Log file

Du coup faison un sudo systemctl restart postgresql@11-main.service

puis de nouveau un sudo pg_lsclusters

pour espérons valider que le cluster a bien démarré

root@game:~# sudo systemctl restart postgresql@11-main.service
Assertion failed on job for postgresql@11-main.service.

Mouarf bon, regardons

journalctl -u postgresql@11-main.service --no-pager --no-hostname -n 100

salut, j ai reussi a installer je te remercie de l aide apporter :wink:

Uh woké mais est-ce que tu pourrais expliquer si tu as fait un truc particulier histoire qu’on voit si on peu empêcher que le même genre de soucis se reproduise pour d’autres personnes…

Desintall et réinstaller postgesql