Custom web apps cannot get sftp to work anymore (permissions issue)

Hello Yunohost people,

I’m using yunohost 2.7.5 and I’ve been adding several custom web apps to my server and recently on my 6th web app it started showing wierd behavior with sftp. For background this yunohost is running as a virtual box vm on a mac and it has well over 100 gigs of space free on the drive image and drive. Sometimes a file would get partially transfered using sftp but most of the time the file would be prevented from copying with a permissions error:

/var/www/my_webapp__6/www/Thermionic Converters_ Problems and Solutions.html: open for write: permission denied|
Error: |File transfer failed|

I’ve tried the webapp6 user and my admin user and still get this error (super user doesn’t have the permissions??).

I did a bunch of things recently to see what I may have done to cause it and I know for certain that:

It isn’t because of the recent yunohost update
It isn’t strictly a customwebapp issue because the multi web app (the one without ftp) also fails the same way.

I got 1024 megs on the vm

The connection is gigabit ethernet, wan can handle 10 megabits upstream

I’ve not done anything fancy with my box or yunohost setup. Here are the apps I have:

Gogs, nextcloud, rainloop, Searx, 5 web apps, phpmyadmin

It gets interesting, in my other web apps I can still sftp files in and out of them. it is only new web apps that fail to give me the proper permissions to allow correct transfers. Sometimes it transfers the first part of the file then panics and the connection closes leaving behind little artifact files with 0 k or a few bytes.

I try apps now and then and delete them, I was wondering if perhaps I have maybe poisoned my yunohost and this sftp issue is a symptom.