Cops - login et mot de passe


#1

Bonjour,
je continue dans mes installations…
J’ai donc installé l’appli “Cops” sur mon serveur et lui ai attribué les droits de mes utilisateurs…
Lorsque je tente de m’y connecter (pour la 1ère fois), l’appli me demande un login et un mot de passe… je re-rentre donc un de mes utilisateurs mais rien à faire… ce n’est pas validé et ai à nouveau la fenetre de connection…
y a t’il un paramètre “générique” lors de la première connection? J’ai fouiné un peu sur le web et particulièrement sur celui de l’auteur mais n’ai rien trouvé de particulier.

Merci de votre aide


#2

My French is not that great, but it seems I have the same problem as you.
https://domain.org/cops prompts for a login and password, but I cannot authenticate with a Yunohost account.
Any suggestions?


List of Apps Working with Yunohost 2.4
#3

Dubwise, I did face the same problem and here is how I managed to get myself COPS working.

Actually there are two problems to solve:

pam_ldap.so x86 path
To solve this I took the following steps:

  • Install libpam-ldapd via “sudo apt-get install libpam-ldapd”
  • Set the right OS in your /etc/pam.d/nginx. In my case “sudo nano /etc/pam.d/nginx” and replace “x86_64-linux-gnu” with “arm-linux-gnueabihf”

White screen after logging in
Here a new “fastcgi” parameter is needed:

  • Open your COPS configuration file “sudo nano /etc/nginx/conf.d/ddns.myliberty.eu.d/cops.conf”
  • Add the the following parameter “fastcgi_param SCRIPT_FILENAME $request_filename;”

Of course you also have to set the right parameters in “/var/www/cops/config_local.php” and take care that your book catalog can be accessed by the server.


#4

Awesome, COPS is running now! Thanks a lot.


#5

Hi,
sorry for my poor english.
I’ve installed libpam-ldapd
My server is a notebook x86… I guess that the initial configuration is good:

auth required /lib/x86_64-linux-gnu/security/pam_ldap.so
account required /lib/x86_64-linux-gnu/security/pam_ldap.so

but after a restart of nginx i’m facing (good in english??) the same problem… the server ask my parameters of connection and block at this step.

thanks for your help


#6

bonjour,
je me permet de relancer le post n’ayant toujours pas eu de réponses à ma question (9j ça me semble correct comme temps d’attente) et malgré mes essais suivant les propositions de Tiberius…
si quelqu’un peut m’aider à débloquer la situation ce serait fort sympathique