Configuration Environmet http_proxy, https_proxy, ftp_proxy

Yunohost is successfully installed on Debian 9. The connection of the maschine to the internet is released over a proxyserver with authentification. In the ssh-console i have a permission to internet (proxy-configuration in etc/environment is correct). Over console i also can install yunohost-apps. Over the Yunohost Webadmintool i have no access to the Internet. Is there anything missing in the php-configuration? Where i have to set the proxy environments for the webserver?

Example-Error installing APP: unable to download
Example-Error Update APP-List: Entfernte Appliste yunohost kann nicht empfangen werden: HTTPSConnectionPool(host=‘’, port=443): Max retries exceeded with url: /apps.json (Caused by NewConnectionError(’: Failed to establish a new connection: [Errno 101] Network is unreachable’,))

If you edited /etc/environment and it does the trick (assuming that it’s not because you also manually sourced / exported vars in the CLI) you can try to restart yunohost-api to hopefully propagate the changes

systemctl restart yunohost-api

the /etc/environment was set before install yunohost. The server also were rebootet after install, so export vars would be deleted. “systemctl restart yunohost-api” not effective… I think the install-routine of yunohost did not take over the environment-settings for proxy-server

But you seem to suggest that installing apps via the CLI works, but not the webadmin ?

That’s puzzling because the underlying code is pretty much the same … Idk, I would have to dig into documentations about how to setup a proxy that’s transparent accross all the system…

Can you try to :

systemctl stop yunohost-api

then in the terminal, manually launch :


The command will hang forever, then in parallel just try to connect to the webadmin and perform an app install …

Once you’re done, you can Ctrl+C to cancel the command and restart the api with systemctl start yunohost-api

That test should clarify if it’s something related to env variables

I tryed it:
systemctl stop yunohost-api

In the Webadmin the install of an APP is now functionally.

Setting up source files…
Creating a MySQL database…
Installing dependencies…
Storing installation settings…
Validating installation parameters…
Anwendung agendav wird installiert…

Alright so that really sounds like something related to env variables …

If you run 'env | grep -i proxy'

do the variables that you defined about the proxy show up ?

Can you tell where you learned about configuring /etc/environment ?

when run ‘env | grep -i proxy’ the list is shown correctly


The info about configuration /etc/environment i had searched… ==>

We should probably include a fix upstream but in the meantime a clean solution I believe should be to run :

systemctl edit yunohost-api

You will enter a mode where you can edit an (initially empty) file

In this file, add the following :


You can save with Ctrl+X (it will ask confirmation, just press Y and Enter)

Then run systemctl restart yunohost-api

Not tested but that should do the trick …

After including the workaround, the app installation works now. Also the update of the applist is functionally. I think, the best solution would be, that in the yunohost-full-installation-routine there is a integration of a query to define an proxy-server, if available/necessary. No i´m beginning to test the function of a few different apps…
First Problem i had by using app nextcloud. Theres no solution to install/activate the deck plugin. I´m not shure yet… can this be a consequential error of the existing proxy-server?

Thank you very much.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.