[Community app] Monica v2.3.1 - Personal Relationship Manager


#21

I’ve never seen this error before. I guess it could be because I revamped the whole scripts, yes.

Since I won’t do another major, backwards-incompatible upgrade to these scripts anymore, is it possible for ypu to make a backup of your data and reinstall monica?


#22

OK, I tried but it is not possible for me to reinstall monica again.
After no Information was shown on the admin interface I used the command line.
Heres the output:
Choose the application language [fr | en] (default: en): en Warnung: dh_install: Compatibility levels before 9 are deprecated (level 7 in use) Warnung: dh_installdocs: Compatibility levels before 9 are deprecated (level 7 in use) Warnung: dh_installdeb: Compatibility levels before 9 are deprecated (level 7 in use) Warnung: E: Pakete müssen entfernt werden, aber Entfernen ist abgeschaltet. Warnung: 2017-10-03 16:40:42 URL:https://codeload.github.com/monicahq/monica/tar.gz/v0.6.5 [4383194/4383194] -> "v0.6.5.tar.gz" [1] Warnung: sudo: /usr/bin/php7.1: Kommando nicht gefunden Warnung: curl: (23) Failed writing body (0 != 16133) Warnung: Unable to install Composer Warnung: !! Warnung: monica's script has encountered an error. Its execution was cancelled. Warnung: !! Warnung: Warnung: Removing database monica Warnung: /etc/nginx/conf.d/monica.domain.de.d/monica.conf wasn't deleted because it doesn't exist. Warnung: /etc/cron.d/monica wasn't deleted because it doesn't exist. Warnung: The user monica was not found Erfolg! Die Konfiguration von SSOwat war erfolgreich Fehler: Installation fehlgeschlagen


#23

Did you do a new, fresh installation of monica?

It seems PHP7.1 was not installed.

Can you ran uname -a on the server and paste the output?


#24

You are right, PHP 7 is not include in debian Jessie… But in debian Stretch.
Maybe in debian Jessie with adding another package source.
Watch at the Monica’s yunohost package project if there’s something about requirements.


#25

Yes, I have uninstalled monica, restarted the server to be on the safe side, and then tried reinstalling monica.

The output was:
Linux my-server 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux
So im on Raspbian GNU/Linux 8.0 (jessie).

Can I install PHP7.1 by hand before monica or may it cause more problems?


#26

Linux my-server 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux

Here’s the problem, you’re using an ARM system. I found no PHP7.1 package for arm systems and monica requires PHP7.1. :frowning:

If you happen to find a working PHP7.1 package for Debian ARM, let me know.


#27

Oh, that sounds bad. But thanks for the quick answer.
Since when is PHP7.1 required? Until now, Monica ran quite well on my Raspberry.

It has nothig to do with this pull request that was merged a day ago?


#28

Maybe there is a config file to choose wich PHP version to use with your install.
I don’t know.
Good luck.
Regards


#29

I’ll try to build it with PHP7.0 again. Last time I tried this, I got the errors mentioned here: https://github.com/monicahq/monica/issues/576#issuecomment-328886146


#30

If I delete the composer.lock it indeed works with php7.0!
However I don’t really want to do this in the install step because there could be dependencies in there that HAVE to be there.
So I asked here how we should proceed.


#31

Many thanks for your effort. I did not want make such a big thing out of it.
But of course, I would be happy if Monica would also be updatable on my Raspberrey since the project evolves rapidly.
Version 1 is comming and it would be to bad if I had to stay at V 0.6.5 or I would have to exchange my RPI for a non-ARM system.

Vielen Dank.


#32

Hi,
since I managed to install the current version of Monica for Yunohost on the Raspery, I wonder if can we still count on an update.
Or have you stopped working on the Monica package for yunohost?


#33

Hi,

I did not stop working on it, however I currently don’t have time to update, sorry! Maybe you want to help? There are extensive tests by now that need to pass: https://ci-apps.yunohost.org/jenkins/job/monica%20(Community)/


#34

Updated the app to version v2.3.0. Tested install,remove,backup and restore scripts.
A mobile app for Monica is available here.


#35

Hi,

Please just tell me the name don’t came from DDLC =S


#36

I did not get what you are asking.


#37

Updated the Monica app to version v2.3.1. Tested install,remove,backup and restore scripts.


#38

Hello,
I have installed Monica and it seems working very well.
I choose to install it “not public”.
Unofrtunately I have to first enter my yunohost account credential and then the Monica credential.
Does that means I should have installed it as a “public” application ?

If yes, is there a way to revert that option ?
Thanks in advance for your advices !


#39

Hi @croulibri
Yes you should have installed it as public app.

You can change it to public by entering this command in the shell:
yunohost app setting monica is_public -v 1

and then updating the app by admin interface or by command line:
yunohost app upgrade -u https://github.com/YunoHost-Apps/monica_ynh monica


#40

Generally speaking, there’s no definitive answer to this.
For practical reasons (don’t type credentials twice), yes.
For security reasons, and provided you don’t intend to provide that service to people who don’t have a YunoHost account, or use a third-party client (e.g. and Android client), it’s interesting to consider that the YunoHost SSO provides an additional security layer that protects you a little bit more (e.g. against a security issue of the app itself, brute-force attack, etc.). :wink: