[CodiMD] Can't install on raspberry

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I am trying to install codimd on my new installation on raspbery pi4 but I get this error:

Info: WARNING - Output:
Info: WARNING - PhantomJS not found on PATH                                    
Info: WARNING - Unexpected platform or architecture: linux/arm                 
Info: WARNING - It seems there is no binary available for your platform/architecture
Info: WARNING - Try to install PhantomJS globally                              
Info: DEBUG - + ynh_exit_properly

Full debug could be read here: https://paste.yunohost.org/raw/kasawotafo

Referenced that issue on github, ping @ericg https://github.com/YunoHost-Apps/codimd_ynh/issues/53

Thanks for your repost!

I tried to install also hedgedoc, installing directly phantomjs on the same computer but I got the same error.
Reported the problem in https://github.com/YunoHost-Apps/hedgedoc_ynh/issues/2

With the testing version of hedgedoc the installation went fine.

sudo yunohost app install https://github.com/YunoHost-Apps/hedgedoc_ynh/tree/1.7.0
1 Like

You should be aware that this is still an upstream beta version … I will upgrate HedgeDoc_ynh as soon as the final version 1.7.0 is available.

1 Like

Yes, I know but now I am trying it on a testing server on raspberry pi4

My message was also intended for other users … :wink:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.