[Closed] Jitsi don't install

Hi everyone,

I tried to install Jitsi on my Briq and didn’t succeed.
Une erreur inattendue est survenue : shell command return code: 1

Hardware: Briq Lime01
YunoHost version: “host”: “Debian 9.11”, “kernel”: “4.19.62-sunxi”,

    "yunohost":  "repo": "stable", "version": "3.6.4.6"
    "yunohost-admin":  "repo": "stable", "version": "3.6.4"
    "moulinette":  "repo": "stable", "version": "3.6.4.1"
    "ssowat":  "repo": "stable",  "version": "3.6.4"

Here is the log file :

2019-10-06 13:29:25,034: WARNING - e[91me[1m[ERR]e[0m !! 2019-10-06 13:29:25,039: DEBUG - + local legacy_args=m 2019-10-06 13:29:25,041: WARNING - jitsi's script has encountered an error. Its execution was cancelled. 2019-10-06 13:29:25,046: DEBUG - + args_array=([m]=message=) 2019-10-06 13:29:25,049: WARNING - !! 2019-10-06 13:29:25,055: DEBUG - + declare -Ar args_array 2019-10-06 13:29:25,057: WARNING - 2019-10-06 13:29:25,064: DEBUG - + local message 2019-10-06 13:29:25,066: DEBUG - + ynh_handle_getopts_args '--message=!!\n jitsi'\''s script has encountered an error. Its execution was cancelled.\n!!' 2019-10-06 13:29:25,069: DEBUG - + set +x 2019-10-06 13:29:25,072: DEBUG - + ynh_print_log '\e[91m\e[1m[ERR]\e[0m !!\n jitsi'\''s script has encountered an error. Its execution was cancelled.\n!!' 2019-10-06 13:29:25,074: DEBUG - + echo -e '\e[91m\e[1m[ERR]\e[0m !!\n jitsi'\''s script has encountered an error. Its execution was cancelled.\n!!' 2019-10-06 13:29:25,077: DEBUG - + '[' api == cli ']' 2019-10-06 13:29:25,079: DEBUG - + type -t ynh_clean_setup 2019-10-06 13:29:25,081: DEBUG - + ynh_clean_setup 2019-10-06 13:29:25,082: DEBUG - + ynh_clean_check_starting 2019-10-06 13:29:25,084: DEBUG - + kill -s 15 2019-10-06 13:29:25,085: DEBUG - kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec] 2019-10-06 13:29:25,087: DEBUG - + ynh_secure_remove '' 2019-10-06 13:29:25,088: DEBUG - + local legacy_args=f 2019-10-06 13:29:25,090: DEBUG - + args_array=([f]=file=) 2019-10-06 13:29:25,092: DEBUG - + declare -Ar args_array 2019-10-06 13:29:25,093: DEBUG - + local file 2019-10-06 13:29:25,095: DEBUG - + ynh_handle_getopts_args '' 2019-10-06 13:29:25,097: DEBUG - + set +x 2019-10-06 13:29:25,098: DEBUG - + echo '! Helper used in legacy mode !' 2019-10-06 13:29:25,101: DEBUG - + set +x 2019-10-06 13:29:25,102: DEBUG - + local 'forbidden_path= /var/www /home/yunohost.app' 2019-10-06 13:29:25,104: DEBUG - + '[' 1 -ge 2 ']' 2019-10-06 13:29:25,106: DEBUG - + [[ /var/www /home/yunohost.app =~ '' ]] 2019-10-06 13:29:25,107: DEBUG - + ynh_print_warn '--message=Avoid deleting .' 2019-10-06 13:29:25,109: DEBUG - + local legacy_args=m 2019-10-06 13:29:25,110: DEBUG - + args_array=([m]=message=) 2019-10-06 13:29:25,112: DEBUG - + declare -Ar args_array 2019-10-06 13:29:25,114: DEBUG - + local message 2019-10-06 13:29:25,116: DEBUG - + ynh_handle_getopts_args '--message=Avoid deleting .' 2019-10-06 13:29:25,117: DEBUG - + set +x 2019-10-06 13:29:25,119: DEBUG - + ynh_print_log '\e[93m\e[1m[WARN]\e[0m Avoid deleting .' 2019-10-06 13:29:25,121: DEBUG - + echo -e '\e[93m\e[1m[WARN]\e[0m Avoid deleting .' 2019-10-06 13:29:25,122: DEBUG - e[93me[1m[WARN]e[0m Avoid deleting . 2019-10-06 13:29:25,124: DEBUG - + ynh_die 2019-10-06 13:29:25,125: DEBUG - + local legacy_args=mc 2019-10-06 13:29:25,127: DEBUG - + args_array=([m]=message= [c]=ret_code=) 2019-10-06 13:29:25,128: DEBUG - + declare -Ar args_array 2019-10-06 13:29:25,130: DEBUG - + local message 2019-10-06 13:29:25,131: DEBUG - + local ret_code 2019-10-06 13:29:25,133: DEBUG - + ynh_handle_getopts_args 2019-10-06 13:29:25,134: DEBUG - + set +x 2019-10-06 13:29:25,136: DEBUG - + echo '' 2019-10-06 13:29:25,137: DEBUG - + exit 1

Full log there : https://paste.yunohost.org/raw/alitaquker
It seems to be the same error as in the thread [Jitsi Meet] Installation failure when installing Jitsi Meet
But I don’t understand how to get through it.

Thanks a lot !

Hi !

As explained here : https://github.com/YunoHost-Apps/jitsi_ynh#important-points-to-read-before-installing ,you have to set up several specific hostnames for Jitsi to install successfully. It seems in your log you tried to install it on your main domain.

Bonjour,

Jitsi Meet for YunoHost

Integration level
Install Jitsi Meet with YunoHost

Lire ce readme en français.

Juste pour signaler que le lien «Lire ce readme en français.» renvoie une erreur 404 !

Je veux bien essayer de proposer, dans les jours qui viennent, une traduction si elle n’existe pas déjà. Et, dans ce cas, peut-être, me faudra-t-il une aide à la publication !
Bonne journée !

Hi @Daz

That’s it ! I didn’t create any subdomain.
So, now with a jitsi.domain.tld I try to install and get the following error message :

2019-10-10 14:12:22,373: DEBUG - + echo 'Configuring metronome...' 2019-10-10 14:12:22,376: DEBUG - + '[' 0 -eq 1 ']' 2019-10-10 14:12:22,378: DEBUG - + yunohost user create svcjitsifocus -f svcjitsifocus -l svcjitsifocus -m svcjitsifocus@auth.jitsi.domain.tld -p ********** -q 0 2019-10-10 14:12:26,536: DEBUG - You are now about to define a new user password. The password should be at least 8 characters - though it is good practice to use longer password (i.e. a passphrase) and/or to use various kind of characters (uppercase, lowercase, digits and special characters). 2019-10-10 14:12:26,541: WARNING - Unknown mail address domain 'auth.jitsi.domain.tld' 2019-10-10 14:12:26,548: INFO - Configuring metronome... 2019-10-10 14:12:26,761: DEBUG - + ynh_exit_properly 2019-10-10 14:12:26,763: DEBUG - + local exit_code=1 2019-10-10 14:12:26,765: DEBUG - + '[' 1 -eq 0 ']' 2019-10-10 14:12:26,766: DEBUG - + trap '' EXIT 2019-10-10 14:12:26,768: DEBUG - + set +eu 2019-10-10 14:12:26,769: DEBUG - + sleep 0.5 2019-10-10 14:12:27,277: DEBUG - + ynh_print_err '--message=!!\n jitsi'\''s script has encountered an error. Its execution was cancelled.\n!!' 2019-10-10 14:12:27,279: DEBUG - + local legacy_args=m 2019-10-10 14:12:27,281: DEBUG - + args_array=([m]=message=) 2019-10-10 14:12:27,283: DEBUG - + declare -Ar args_array 2019-10-10 14:12:27,285: DEBUG - + local message 2019-10-10 14:12:27,286: DEBUG - + ynh_handle_getopts_args '--message=!!\n jitsi'\''s script has encountered an error. Its execution was cancelled.\n!!' 2019-10-10 14:12:27,293: DEBUG - + set +x 2019-10-10 14:12:27,396: DEBUG - + ynh_print_log '\e[91m\e[1m[ERR]\e[0m !!\n jitsi'\''s script has encountered an error. Its execution was cancelled.\n!!' 2019-10-10 14:12:27,398: WARNING - e[91me[1m[ERR]e[0m !! 2019-10-10 14:12:27,403: DEBUG - + echo -e '\e[91m\e[1m[ERR]\e[0m !!\n jitsi'\''s script has encountered an error. Its execution was cancelled.\n!!' 2019-10-10 14:12:27,405: WARNING - jitsi's script has encountered an error. Its execution was cancelled.

L’installation a de nouveau échoué.

Entre temps, j’ai installé un certificat pour le sous-domaine et relancé l’installation.
Ça dure sérieusement…
Je vois plusieurs chose qui posent problème :

E: The repository 'https://download.docker.com/linux/debian stretch Release' does no longer have a Release file.

Docker? Pourquoi Docker?

Pour le moment, Pacman grignotte, suite à Installation of N - Node.js version management
J’en suis à Setting up source files... qui semble poser des problèmes.

Well, it seems you created the jitsi.domain.tld subdomain, but this is a generic exemple. In your case, it should be jitsi.harpo-bzh.nohost.me (replace “domain.tld” with your own domain). And you have to create the 4 others also.

:fr: Le “jitsi.domain.tld” de la doc est un exemple que tu dois adapter à ton propre domaine. Dans ton cas ce doit être : “jitsi.harpo-bzh.nohost.me” d’après ton log. Et il faut également créer et certifier les 4 autres domaines cités dans la doc.
Seulement je ne suis pas sûr que les sous-domaines fonctionnent avec les nohost.me, car les enregistrement DNS ne sont peut-être pas mis à jour automatiquement…

Hi @Daz,
I just changed the name to be more generic, assuming that someone could have a similar question.
Concerning the four other domain, I thought there just were samples !
:crazy_face:

In the mean time the api is broken. I have to reboot the server.
Jitsi app is here. I deinstall it.
Then I created the four domains with a certif before reinstall it.
The install aborts and the api break.

Here is the log : https://paste.yunohost.org/raw/nogogaqoho

What do you mean by " je ne suis pas sûr que les sous-domaines fonctionnent avec les nohost.me, car les enregistrement DNS ne sont peut-être pas mis à jour automatiquement "? Quelle serait la limitation des sous-domaines?

Merci !

OK, from what I understand, you miss some dependency, but I don’t know which one. It may be an error from the server from which the script downloads the packages, as the log says :

2019-10-11 09:20:29,352: DEBUG - [ERROR] Failed to execute goal on project jicofo: Could not resolve dependencies for project org.jitsi:jicofo:jar:1.1-SNAPSHOT: Failed to collect dependencies at org.jitsi:jitsi-protocol-jabber:jar:2.13.3ee5751 -> org.igniterealtime.smack:smack-bosh:jar:4.2.4-47d17fc: Failed to read artifact descriptor for org.igniterealtime.smack:smack-bosh:jar:4.2.4-47d17fc: Could not transfer artifact org.igniterealtime.smack:smack-bosh:pom:4.2.4-47d17fc from/to jitsi-maven-repository-releases (https://github.com/jitsi/jitsi-maven-repository/raw/master/releases/): Failed to transfer file: https://github.com/jitsi/jitsi-maven-repository/raw/master/releases/org/igniterealtime/smack/smack-bosh/4.2.4-47d17fc/smack-bosh-4.2.4-47d17fc.pom. Return code is: 504 , ReasonPhrase:Gateway Time-out. -> [Help 1]

I can’t help further on this one, maybe you can try to reboot and reinstall ?

Moreover, I confirm that the subdomains won’t work with a nohost.me server : https://yunohost.org/#/dns_nohost_me_fr
So unless you get your own domain with access to the DNS configuration, I’m afraid you could not use Jitsi on your server :confused:

Hi @Daz,

I’m afraid that you’re right concerning the subdomains on nohost.me.
So long Jitsi for me ! :sob:
It would have been cool for me to play with this project full of potential.

Thanks to you for your help and didactic, @Daz !