Changing "portal_path" to "/" makes apps return 403

My YunoHost server

Hardware: VPS bought online
YunoHost version: 4.3.6.3.
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hello guys!

Been using yunohost for a couple of days now and it’s really awesome. Everything seems to work great except one small thing that bugs me as I’m pretty sure it worked and now doesn’t.

I have set “portal_path” to just “/” inside /etc/ssowat/conf.json and now when I try to load an app from the portal I get a 403 Forbidden. If I type in anything else e.g. “/test/” it works perfectly. I’m still able to login while the portal_path is set to “/” but apps seem unauthenticated. Any idea why?

Thanks

Welcome!

Can you share your NGINX service logs right after triggering that error?

You want the root of the domain to bring you to the user portal, correct? If so, I would advise you not to hack into SSOwat but rather install a Redirect app on yourdomain.tld/ that sets a 302 redirection towards yourdomain.tld/yunohost/sso.

1 Like

Yes, my goal is to have the portal available in the root of a subdomain domain I prepared, without a redirect or displaying /yunohost/sso. I think that would be a really clean solution.

I checked the my-domain-error.log and error.log inside /var/log/nginx but it contains nothing related to the 403 that occurs.

Okay, I just found out that the 403 is gone and everything works if I change the URL of the app I installed inside after setting portal_path to /… Just noticed that it breaks the admin panel tho… Hmmm… If you have no other solution for what I want to achieve, I’ll just stick with the default. Thanks

Maybe try the redirect app in proxy mode? I’m not sure it’s compatible though.

1 Like

Note: you should not change /etc/ssowat/conf.json instead do the change in /etc/ssowat/conf.json.persistent

But this advice won’t fix your issue. Changing the portal is an advanced use case. It seems some url are hardcoded in ssowat:

1 Like