Can't update to beta

When I run the command from the instructions nothing appears in the webadmin interface.
The following output is the log from running the command “curl https://install.yunohost.org/switchtoTesting | bash”
curl https://install.yunohost.org/switchtoTesting | bash % Total % Receive - Pastebin.com

The following are my yunohost version numbers:
yunohost:
repo: stable
version: 4.3.6.3
yunohost-admin:
repo: testing
version: 4.3.4.1
moulinette:
repo: stable
version: 4.3.3.1
ssowat:
repo: stable
version: 4.3.3.1

I fixed the first issue and managed to start the update.

The installation fails after displaying " 1. E: Unable to correct problems, you have held broken packages." It then lists all of my packages which are installed on the server. It looks like it is listing every single program that is installed.

What could be going wrong?

Error log: Running migration 0021_migrate_to_bullseye...Starting migration to BullseyeP - Pastebin.com

Try to upgrade before your system:

yunohost tools upgrade system

If it doesn’t work, it seems related to archivebox-ynh-deps.

May be you could try to force upgrade it:

yunohost app upgrade archivebox -f

How do I completely uninstall a webapp? I uninstalled Archivebox via the webpanel but its files are still present and I am still getting the same dependency error.

Force upgrading archivebox gave me an error so I uninstalled through the panel.
The first command is giving me the exact same error as I was getting through tools > migrations.

After speaking to Tituspijean on the IRC channel I was able to manually remove the dependency.
Here is the removal log for Archivebox https://paste.yunohost.org/raw/exevoruvim

Strangely yunohost doesn’t remove the dependencies completely.
This can be fixed with the following line provided by tituspijean.
sudo apt remove archivebox-ynh-deps

For the first issue I was having I simply had to do a system update through the web admin panel after I ran the command from the instructions. After this the button to migrate the system appeared in ‘tools → migrations’. This is something that should be added to the instructions just in case someone is having the same issues.

Thank you all!

1 Like