Cant install Nextcloud. Suddenly


Newish install of Yuno Host on a VPS.

Install has been great so far. Very good. I managed to install Nextcloud with Onlyoffice.

However, today, don’t know why on new installs I cannot install Nectcloud.

Halfway through the install I get:

You cannot do this right now because dpkg/APT (the system package managers) seems to be in a broken state… You can try to solve this issue by connecting through SSH and running sudo apt install --fix-broken and/or sudo dpkg --configure -a.

I cannot find a log and I have tried to run the install and config as sudo but with no change.

The install ends with a message that the inside of the Nextcloud script is broken.

Has anyone else had this over the past few days? Has the Nextcloud install script changed?




Let’s try to run what the message says. If you run

sudo apt install --fix-broken


sudo dpkg --configure -a

What do you get?


HI there @Kayou many thanks for your reply.

So here we go, with:
sudo apt install --fix-broken

Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

with sudo dpkg --configure -a

I get: Nothing. It just returns to the prompt and that’s with a brand new install…

Thank you


Can you try dpkg --audit ?

Hello and thanks @Aleks

I assume as sudo?

I tried both

dpkg --audit


sudo dpkg --audit

both of these do nothing, just returned to the prompt.

It’s very very odd this as I was able to get a full working Nextcloud instance on a fresh install a few days ago, however same server same situation a few days later, and now nothing… All other apps install without any problems at all…

Best wishes


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.