Can't install more than one app

I just installed Yunohost (stable) on my VPS. Everything works fine except for one problem: I cannot install more than one App. I have installed Roundcube and if I try to install another App the Installation fails. In the logs I always find the same error:

"This url is not available or conflicts with the already installed app(s):

2019-03-03 10:03:28,469: DEBUG - + local exit_code=1
2019-03-03 10:03:28,469: WARNING - * mydomain/webmail → Roundcube (roundcube)
2019-03-03 10:03:28,470: DEBUG - + trap ‘’ EXIT
2019-03-03 10:03:28,470: WARNING - !!

This seems to be a problem with the domain and the installation path. When I choose as domain I can install another app, but just one as well.

The apps seem to try to install themselves in the root path of the domain as the local path=/. and stop the installation, if they see that there already is an app installed there.

Whats the problem here? Did I do something wrong, when adding the domains to Yunohost? How can I change the path where apps install themselves? (This problem doesn’t affect simpel apps like HTMPTools which install themselves in another path…)

Somebody correct me if I am wrong, but I think the app installation has to be built to prompt you for a sub-directory (and only some apps support that). If it doesn’t, it takes over the entire domain and you might not be able to install anything else beside it.

For that reason I started to create subdomains for every app… No conflicts this way.

I’m quite sure that it was possible in yunohost 2.4 to install several Apps, but perhaps I’m wrong.

How do you install the apps in subdomains? Im quite a newbie when it comes to self-hosting.



Yes, it is possible to install several apps on a single domain … but you must beware of conflicts.

So for instance you cannot have the following situation :

domain.tld/           -> Nextcloud
domain.tld/webmail    -> Rainloop

Nor the following situation :

domain.tld/files      -> Nextcloud
domain.tld/           -> Rainloop

However you can have the following situation :

domain.tld/files      -> Nextcloud
domain.tld/webmail    -> Rainloop

So basically, you cannot have an application at the root of the domain and other apps in subpaths for the same domain …

Applications should ask you in which domain + subpath to install - except for some applications which require a full domain.

Can you clarify what app you are trying to install exactly ?

Thanks for the clarification! I tried different Apps, Roundcube, and then Kimai, Cachet or Nextcloud. Doesn’t work when I install Roundcube first, although its in its separat /Webmail directory.

When you set up the DNS for your main domain you set an A record for to point to the IP address of the server. I think all you have to do is set another A record of pointing to that very same IP address. And then you can add a new domain in Yunohost to be “”. At least that is what is working for me - I am also new to this. :grimacing:

1 Like