Can't add any app or go to backup after upgraded to 4.1.6

Hello and thank a lot for what you do for yh.

My YunoHost server

Hardware: Old laptop x86
YunoHost version: 4.1.6 (stable)
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | ALL
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
I tried to install the PeerTube youtube sync.

Description of my issue

After that I have upgraded to the latest version I cannot add any app.

Could you please help me?

Thank you and have a good day.

If I go to backup I see a similar error.

(I cannot put more than one image for post since I’m a new member)

It sounds like you are in some inconsistent state:

  • maybe try to restart the yunohost-api with systemctl restart yunohost-api
  • does dpkg --audit complains about something ?
  • does dpkg --list | grep yunohost display 4.2.x versions for both yunohost and yunohost-admin ?

Thank you for your answer.

  1. Still not working.
  2. It doesn’t show anything.
  3. Last command show
    yunohost 4.1.6
    yunohost-admin 4.2.3

It seems that it’s not the last version!

Well then, let’s try to “apt install yunohost” (which should actually upgrade the package)

Thanks, it was super easy and now it works.

I still had some problems with PeerTube but then I’ve updated npm to the last version and now everything works perfectly.

Thank you a lot!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.