Can't access rebuilt Nitter on original url

My YunoHost server

Hardware: vps on PulseHeberg
YunoHost version: I don’t know how to get it, but it is the latest
I have access to my server : ssh
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : I installed Nitter but rebuilt it on another branch (guest_accounts) as it is necessary to make it work

Description of my issue

I installed Nitter on nitter.domain.tld
Then I stopped the service and rebuilt it
Nitter (rebuilt on guest_accounts branch) works fine when installed on any url but not on the original one (I get Server Not Found on Firefox)

  • I used yunohost app change-url, no manual edit to config files
  • I checked nginx logs there is no errors
  • I can curl Nitter homepage from the same server

Any ideas on how to troubleshoot / solve this ?


Yes, explain precisely what “does not work fine on the original URL” looks like. A screenshot is most welcome.

I get a Server Not Found on Firefox
Also I tried to remove and re add the url but it didn’t solve the problem

Refresh your browser cache (CTRL+SHIFT+R) and try again, then share the Nitter service logs from your webadmin.

Refreshing the cache doesn’t work
Here’s the Nitter log: hastebin
I ran nimble md but it still doesn’t work

I found an error that might be related on this log (nginx): hastebin line 547

To be 100% sure it is not a browser cache issue, can you try in a private browser session?

I am not sure the nimble md suggestion is the solution, but who knows. Open an app shell session with yunohost app shell nitter, then try nimble md again.

connect() failed (111: Connection refused) while connecting to upstream

This usually means the service is not running, but it is, isn’t it?

It still fail to open Nitter on private browsing
Yes, the service is started
Runing nimble md again gave me this error

oserr.nim(94)            raiseOSError
Error: unhandled exception: Permission denied
Additional info: "/var/www/nitter/.nimble/pkgs/sha1-1.1" [OSError]
stack trace: (most recent call last)
/tmp/nimblecache-3747440334/nimscriptapi_275691389.nim(187, 16)
/var/www/nitter/nitter.nimble(34, 8) mdTask
/usr/lib/nim/system/nimscript.nim(273, 7) exec
/usr/lib/nim/system/nimscript.nim(273, 7) Error: unhandled exception: FAILED: nimble c --hint[Processing]:off -d:danger -r tools/rendermd [OSError]
     Error: Exception raised during nimble script execution

I think it night be related to the fact that some files on /var/www/nitter are owned by the root user
I will retry after running chown -R nitter:nitter . (it fixed the permission error)

1 Like

Ok I managed to fix it
I ran a diagnosis and got an error in dns records
I added suggested records for nitter and now it works fine !

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.