Can't access my server over domain

My YunoHost server

Hardware: Raspberry Pi 2b
YunoHost version:
I have access to my server : With local IP: Through SSH | through the webadmin | and direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hello, I can’t access to my yunohost server with the domain name (""), however, everything is fine if I access with the local IP.
I tried with looking for errors I saw from other post, but It doesn’t seem like a connection error.

What I already tried:

dig +short

It shows my public IP, so everything seems fine.

yunhost dynds update

Output log here:

As @tituspijean requested, here is the log og yunohost-api after I trigger “ERROR: 500”

Hello, and welcome!

There is a Support message template that you ignored. Use it.

While we wait for you to fill in the template, can you share the yunohost-api service log right after you trigger that error 500?

Thank you, first sorry I didn’t follow the template early, I was a little confused. I already edited my post with, hopefully, the correct format.
Here is the yunohost-api log as you requested: hastebin

Can you access your domain name using your phone, not connected to your local network?

Did you set up port-forward on your ISP modem?

No, I can’t access outside my local network. I checked the port-forwarding on my router and everything seems fine (I also checked it with the yunohost Diagnosis tab).

I don’t see a 500 error in the API log. Maybe your router is capturing the port you’re requesting? What port does the admin portal for your router use?

It uses HTTP, so port 80. I also checked pinging the server from other computer, and it seems it tries to connect to a different IP, so my server’s public IP has changed, but I don’t know why my yunohost doesn’t update the dynDNS

Can you change the port used by the router web interface? It might be intercepting your request to the Yunohost machine.

No I don’t think I can. I’ve been using Yunohost for nearly a year now, It is the first time I can’t access outside my home network, so I’m not sure if it’s really related to my router.
Moreover, if I type my public IP, I can access to my server, so It seems something with the “” domain

So, summarizing:

  • Your Yunohost has been available at for around a year
  • Now it is not available at the domain anymore, but it is reachable by IP
    • Is that your public IP or the IP on the LAN?
    • I can’t access outside my local network, is that by IP or domain?
  • You checked whether your public IP changed, and the result matches the IP given by Yunohost’s diagnosis / router status page / ‘whatismyip’, or some such website

Are there any warnings in Yunohost’s diagnosis?
I have access to my server : With local IP : so, not via the public IP?
Does your ISP provide a dynamic IP or static? Has power been of the router recently, or has it maybe been reset (after the the provider pushed a firmware upgrade, for example)?

By the way, welcome to the forums!

So when you ping your domain name you don’t get your actual public ip address. Your domain is listed in the domains (in webadmin) and the dns configuration says everything is OK.
Check tools > logs. I have a log entry everytime dyndns has updated the ip address and if it fails I get an email in the administrator account.
You can ping dyndns of yunohost so connection seems fine.
May be the dyndns app is not working correctly or lost its settings. From here I’m unable to help. I never tried to explore it.

Thank you all of you who have tried to give this a shot, I will try to summarize everything I have tried so far:

  • My server is available through: Local IP (HTTP), Public IP (HTTP)
  • I can’t access through my Yunohost Domain “”

I tried going to DNS Config on the Admin Panel but when I click the button, It gives the following errror 500: hastebin

I checked the logs again, and It’s full of the same error “can’t update IP for your domain” (or something similar). Log here:

I tried also with the yunohost dyndns update command but fails with the same error 500.

I checked and verified the ports on my router, and everything seems fine (I also tried deactivating and reactivating the port forwarding).
It seems that my public IP has changed, but my server can’t update the domain to point to my new IP.

It may be a problem with a config file on dyndns, but I cannot find any mention of where to find the file.

It seems that your pkg-resources is missing or malfunctioning, try reinstalling it

sudo apt-get install --reinstall python3-pkg-resources

Reinstalled and rebooted the server… Same error:
I have tried also reinstalling python3, but the error persists.

Okay so, I’ve got news. After @jarod5001 message, I tried looking for python related errors on the internet. Another similar issue I found on StackOverflow proposed this fix:

sudo pip3 install --upgrade setuptools

After a reboot and running sudo yunohost dyndns update It seems it fixes my issue too!

Thank you very much to everyone who have tried to help me with this issue. I don’t know why it happened or why pip3 didn’t selfupdate the setuptools package, but everything seems fine now.


Great! To help us debug what happened, could you share your installed apps list? (I am thinking about an app that ran commands outside a virtual environment).

1 Like

Sure, I have installed:

  • Navidrome
  • Dokuwiki
  • Freshrss
  • Unnatended-Upgrades

The last Navidrome update reverted my config file to default (maybe It doesn’t relate, but who knows). Let me know if I can help in any other way.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.