Cannot upgrade and migrate to YunoHost 3


My English may be approximate and i’m not a package management specialist.
Fisrt, i’ll try to execute the command given by APT

sudo apt --fix-broken install

Then try to install dependencies, update and upgrade

sudo apt -f install && sudo apt update && sudo apt dist-upgrade

And finally i’ll try to install packages with dependencies one-by-one trying the following one if the first one returns an error.

sudo apt install -f dovecot-core
sudo apt install -f dovecot-antispam


Thanks - your English is fine and far better than my French.
I tried the steps you mentioned (again) but to no avail.
I’ll reload my backup and try again from scratch.

ca n’a pas fonctionné.

Ci les differentes sorties au commandes

root@morgand:/etc/yunohost/dyndns# more old_ip
*root@morgand:/etc/yunohost/dyndns# more old_ip_ori *
root@morgand:/etc/yunohost/dyndns# yunohost dyndns update
Info : No updated needed.
root@morgand:/etc/yunohost/dyndns# yunohost dyndns update --debug
945 DEBUG loading actions map namespace ‘yunohost’
1113 DEBUG extra parameter classes loaded: [‘comment’, ‘ask’, ‘password’, ‘required’, ‘pattern’]
1115 DEBUG initializing base actions map parser for cli
1124 DEBUG registering new callback action ‘yunohost.utils.packages.ynh_packages_version’ to [’-v’, ‘–version’]
1706 DEBUG lock has been acquired
2135 DEBUG loading python module yunohost.dyndns took 0.428s
2138 INFO processing action [7150.1]: yunohost.dyndns.update with args={‘domain’: None, ‘key’: None, ‘dyn_host’: ‘’, ‘ipv4’: None, ‘ipv6’: None}
2143 DEBUG Building zone update file …
6660 DEBUG Starting new HTTPS connection (1):
6948 DEBUG “GET / HTTP/1.1” 200 11
6978 DEBUG Starting new HTTPS connection (1):
7000 DEBUG Could not get public IPv6 : URL invalide : ce site existe-t-il ?
7002 DEBUG Old IPv4/v6 are (, None)
7004 DEBUG Requested IPv4/v6 are (, None)
7005 INFO No updated needed.
7007 DEBUG action [7150.1] executed in 4.867s
7008 DEBUG lock has been released

Thank you ! This advice worked for me !
The first command did it !

dpkg --force-overwrite -i /var/cache/apt/archives/mariadb-server-core-10.1_10.1.38-0+deb9u1_armhf.deb