Cannot upgrade and migrate to YunoHost 3

Still a problem with the dependencies as before:

Canceled hold on nextcloud-ynh-deps.
root@YunoHost:~# Reading package lists…
Building dependency tree…
Reading state information…
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
mariadb-server-10.0 : Depends: mariadb-client-10.0 (>= 10.0.38-0+deb8u1) but it is not going to be installed
Depends: mariadb-server-core-10.0 (>= 10.0.38-0+deb8u1) but it is not going to be installed
moulinette : Depends: python-tz but it is not going to be installed
php-apcu : Depends: php-common (>= 1:7.0+33~) but it is not going to be installed
Depends: phpapi-20151012
Recommends: php-apcu-bc but it is not going to be installed
php-zip : Depends: php-common but it is not going to be installed
Depends: php7.0-zip but it is not going to be installed
yunohost : Depends: python-jinja2 but it is not going to be installed
Depends: python-toml but it is not going to be installed
Depends: apt-transport-https but it is not going to be installed
Depends: jq but it is not going to be installed
Depends: php-mysql but it is not going to be installed or
php-mysqlnd
Depends: unscd but it is not going to be installed
Depends: postsrsd but it is not going to be installed
Depends: php-fpm
Depends: php-ldap
Depends: php-intl
Depends: rspamd (>= 1.6.0) but 1.3.5-1 is to be installed
Recommends: php-gd
Recommends: php-curl
Recommends: php-mcrypt
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).
Migration complete!

apt --fix-broken install
results also in an error:

dpkg: error processing archive /var/cache/apt/archives/mariadb-server-core-10.1_10.1.38-0+deb9u1_armhf.deb (–unpack):
trying to overwrite ‘/usr/bin/mysql_install_db’, which is also in package mariadb-server-10.0 10.0.38-0+deb8u1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/mariadb-server-core-10.1_10.1.38-0+deb9u1_armhf.deb
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_TIME = “de_DE.UTF-8”,
LC_MONETARY = “de_DE.UTF-8”,
LC_MEASUREMENT = “de_DE.UTF-8”,
LANG = “en_GB.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to a fallback locale (“en_GB.UTF-8”).
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_TIME = “de_DE.UTF-8”,
LC_MONETARY = “de_DE.UTF-8”,
LC_MEASUREMENT = “de_DE.UTF-8”,
LANG = “en_GB.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to a fallback locale (“en_GB.UTF-8”).
E: Sub-process /usr/bin/dpkg returned an error code (1)

Wierd

Uuuugh…

Well, let’s try to :

apt --fix-broken install
results also in an error:

dpkg --configure -a --force-overwrite

? :confused:

Hi Aleks,
sorry for the delay and btw; thanks so much for the great support even on a Saturday!!

Anyways,

dpkg --configure -a --force-overwrite

worked without any errors.

Then tried

apt --fix-broken install

again - same errors as before.
Unpacking mariadb-server-core-10.1 (10.1.38-0+deb9u1) ...
dpkg: error processing archive /var/cache/apt/archives/mariadb-server-core-10.1_10.1.38-0+deb9u1_armhf.deb (--unpack):
 trying to overwrite '/usr/bin/mysql_install_db', which is also in package mariadb-server-10.0 10.0.38-0+deb8u1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:

Seems that the migrate has worked though as entering
yunohost tools migrations migrate --accept-disclaimer
results in
Warning: No migrations to run

Nextcloud isn’t working (no surprise there with Maria having problems) and
Yunohost is still 2.7.14.6 but the main system is Debian 9.9…

Thanks once again and have a great weekend
Fil

Zbleh …

So maybe let’s try this :

dpkg --force-overwrite -i /var/cache/apt/archives/mariadb-server-core-10.1_10.1.38-0+deb9u1_armhf.deb

Or maybe if it doesn’t work :

apt-get -o Dpkg::Options::="--force-overwrite" install -f

(then we’ll see about Yunohost not being in 3.x)

The first command seems to have worked:

The first command seems to have worked:

dpkg: warning: overriding problem because --force enabled:
dpkg: warning: trying to overwrite ‘/usr/bin/mysql_install_db’, which is also in package mariadb-server-10.0 10.0.38-0+deb8u1
dpkg: warning: overriding problem because --force enabled:
dpkg: warning: trying to overwrite ‘/usr/bin/mysql_upgrade’, which is also in package mariadb-server-10.0 10.0.38-0+deb8u1
dpkg: warning: overriding problem because --force enabled:
dpkg: warning: trying to overwrite ‘/usr/share/man/man1/mysql_install_db.1.gz’, which is also in package mariadb-server-10.0 10.0.38-0+deb8u1
dpkg: warning: overriding problem because --force enabled:
dpkg: warning: trying to overwrite ‘/usr/share/man/man1/mysql_upgrade.1.gz’, which is also in package mariadb-server-10.0 10.0.38-0+deb8u1
Setting up mariadb-server-core-10.1 (10.1.38-0+deb9u1) …
Processing triggers for man-db (2.7.5-1~bpo8+1) …

Learning a lot about dpkg here :slight_smile:

Learning a lot about dpkg here :slight_smile:

Ah !

So maybe let’s try a :

apt install -f

which should clear remaining things

Then maybe this I guess :

apt install yunohost=3.6.4.3 moulinette=3.6.4 ssowat=3.6.4 yunohost-admin=3.6.4

Don’t you guys have a national holiday today? :slight_smile:

Thanks - seems like we’re getting there.
I got some errors (sorry that it’s in German - played with the locale this morning)

Warnung: Exception AttributeError: “‘Authenticator’ object has no attribute ‘con’” in <bound method Authenticator.del of <moulinette.authenticators.ldap.Authenticator object at 0x75e88dd0>> ignored
Fehler: Skriptausführung fehlgeschlagen: /usr/share/yunohost/hooks/conf_regen/12-metronome

Warnung: Exception AttributeError: “‘Authenticator’ object has no attribute ‘con’” in <bound method Authenticator.del of <moulinette.authenticators.ldap.Authenticator object at 0x75e07df0>> ignored
Fehler: Skriptausführung fehlgeschlagen: /usr/share/yunohost/hooks/conf_regen/15-nginx

Warnung: Exception AttributeError: “‘Authenticator’ object has no attribute ‘con’” in <bound method Authenticator.del of <moulinette.authenticators.ldap.Authenticator object at 0x75e63df0>> ignored
Fehler: Skriptausführung fehlgeschlagen: /usr/share/yunohost/hooks/conf_regen/43-dnsmasq

Warnung: Exception AttributeError: “‘Authenticator’ object has no attribute ‘con’” in <bound method Authenticator.del of <moulinette.authenticators.ldap.Authenticator object at 0x75e55df0>> ignored
Fehler: Skriptausführung fehlgeschlagen: /usr/share/yunohost/hooks/conf_regen/31-rspamd
Launching migrations…
In

(I only included the output which seems to be of interest)

Then
Erfolg! Successfully ran migration 4 php5_to_php7_pools!
Info: Running migration 5 postgresql_9p4_to_9p6…
Warnung: Postgresql was not installed on your system. Nothing to do!
Erfolg! Successfully ran migration 5 postgresql_9p4_to_9p6!
Warnung: Migration 6 sync_admin_and_root_passwords has to be ran manually. Please go to Tools > Migrations on the webadmin, or run yunohost tools migrations migrate.

I hope the errors are nothing major so that I can run yunohost tools migrations migrate.?

Ah well, my bad, maybe can you try to uh, reverse the order of moulinette and yunohost in the command line I gave previously ? Or install first the new version of moulinette, and then yunohost ?

Ah I guess you’re talking about that day people fought against the religious oligarchy and told it to go fuck itself, and now we have a new capitalist and bureacratic oligarchy organizing a demonstration to show how many fancy guns it has, so that people not happy with the goverment should be very much afraid, and dictatorships in middle-east and africa can buy those ? What a nice way to celebrate freedom indeed ¯\_(ツ)_/¯

that doesn’t seem to help:

root@YunoHost:~# apt install moulinette=3.6.4
...
moulinette is already the newest version (3.6.4).
...
0 upgraded, 0 newly installed, 0 to remove and 368 not upgraded.
Then re running the complete set of installations:
...
moulinette is already the newest version (3.6.4).
ssowat is already the newest version (3.6.4).
yunohost is already the newest version (3.6.4.3).
yunohost-admin is already the newest version (3.6.4).
...
Should I remove the progs and reinstall them with moulinette first?


I couldn’t agree more! Seems that politicians and industry are really screwing up in the whole western world (the rest isn’t much better either as it seems).
Germany is no better with apparently a laws etc. being written by lobbyists so the politicians have time to spout their shit at TV cameras.

Hmokay so it sounds like the software is up to date and we should just run the migration

You should be able to run those from the Webadmin if you want (in Tools > Migrations)

or from the command line with yunohost tools migrations migrate

and follow the instructions (and read the disclaimers) :wink:

OK - now it’s getting a bit messy :frowning:

The webadmin doesn’t work and if I try to log in via ssh as root it asks me for the root password then closes the connection immediately.

I guess that this is a problem with the passwords not getting migrated as I saw in one of the messages.

Should have left my PC running an connected to the yuno I guess.

If you have any ideas then I’ll try them but if not then I’ll blast the dd-copy i did of the server before then run through the instructions you sent me.

Thanks again for the great help.

Cheers

Fil

What happens if you try to connect as admin ?

Unfortunately nothing any more - it just hangs on the ssh command and nothing more happens.

I can ping the device so it seems to be responding.

btw: I’m connecting via the local IP address and not via the external dynamic address (tried that now and apparently no route to host).

I can get onto the normal webpage but if I try to access the webadmin I get a message that yunohost has encountered an internal error :confused:
:confused:

OK - so now I get through ssh local but then it closes the connection immediately also for admin:

fil@fil-desktop:~$ ssh admin@192.168.178.26
admin@192.168.178.26’s password:
Linux YunoHost 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Connection to 192.168.178.26 closed.

Hmmokay, maybe you’re getting banned sometimes due to fail2ban … Do you happen to have some SSH keys in your ~/.ssh (that usually triggers “false” failed login attempts which then makes you get banned by the machine idk)

Just got round to checking and there are, funnily enough, no keys for either the external or home-lan addresses fitting to my yuno-box.

There are a couple of keys in there but mostly pretty old.

I#ve prepared an SD-card with the backup of my server and will probably start bashing through that from your instructions tomorrow evening.

I’ll let you know how I get on.

Cheers

Fil

Echec pour moi : j’ai les messages suivant quand je fait
apt update && apt dist-upgrade && apt autoremove && apt autoclean
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://forge.yunohost.org/debian stretch InRelease
Hit:3 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Hit:4 http://apt.syncthing.net syncthing InRelease
Reading package lists… Done
Building dependency tree
Reading state information… Done
278 packages can be upgraded. Run ‘apt list --upgradable’ to see them.
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
dovecot-antispam : Depends: dovecot-abi-2.2.abiv13 but it is not installable
dovecot-imapd : Depends: dovecot-core (= 1:2.2.13-12~deb8u6) but 1:2.2.27-3+deb9u4 is installed
dovecot-ldap : Depends: dovecot-core (= 1:2.2.13-12~deb8u6) but 1:2.2.27-3+deb9u4 is installed
dovecot-lmtpd : Depends: dovecot-core (= 1:2.2.13-12~deb8u6) but 1:2.2.27-3+deb9u4 is installed
dovecot-managesieved : Depends: dovecot-core (= 1:2.2.13-12~deb8u6) but 1:2.2.27-3+deb9u4 is installed
dovecot-sieve : Depends: dovecot-core (= 1:2.2.13-12~deb8u6) but 1:2.2.27-3+deb9u4 is installed
libalgorithm-diff-xs-perl : Depends: perlapi-5.20.0 but it is not installable
libclass-c3-xs-perl : Depends: perlapi-5.20.0 but it is not installable
libdbd-mysql-perl : Depends: perlapi-5.20.2 but it is not installable
libfcgi-perl : Depends: perlapi-5.20.2 but it is not installable
libfile-fcntllock-perl : Depends: perlapi-5.20.0 but it is not installable
libgssapi-perl : Depends: perlapi-5.20.0 but it is not installable
libhtml-parser-perl : Depends: perlapi-5.20.0 but it is not installable
libnet-dns-perl : Depends: perlapi-5.20.2 but it is not installable
libnetaddr-ip-perl : Depends: perlapi-5.20.0 but it is not installable
libparams-util-perl : Depends: perlapi-5.20.0 but it is not installable
libperl5.20 : Depends: perl-base (= 5.20.2-3+deb8u12) but 5.24.1-3+deb9u5 is installed
libsocket6-perl : Depends: perlapi-5.20.0 but it is not installable
libterm-readkey-perl : Depends: perlapi-5.20.0 but it is not installable
libtext-soundex-perl : Depends: perlapi-5.20.0 but it is not installable
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

HELP

Bonsoir,

De ce que je comprends, il y a un souci pour effectuer la migration de YunoHost v2.x basée sur Jessie (Debian 8) vers YunoHost v3.x basée sur Stretch (Debian9), et cela sur un Raspberry Pi.

En faisant un tour là YunoHost 3.0 (Stretch) release / Sortie de YunoHost 3.0 (Stretch) il y les préalables (mise à jour vers YunoHost v2.7.14) avant d’effectuer la migration dont la procédure se trouve ici https://yunohost.org/#/jessie_stretch_migration.

Si ce qui coince est le warning à propos des locales, il faut les définir via le panel du Raspberry Pi :

sudo raspi-config

  • Menu 4
  • I1 pour paramètrer les locales (fr_FR.UTF-8)

Puis relancer la commande préconisée par le gestionnaire de mise à jour :

apt --fix-broken install

En espérant qu’avec tout ça la migration puisse se faire/terminer dans de meilleurs conditions.

ppr