Cannot renew cert - challenge did not pass for muc

My YunoHost server

Hardware: VPS
YunoHost version: 11.1.19
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I received an email overnight alerting me that cert renewal had failed on my primary domain because the challenge failed for the muc subdomain.

Paste here:

I tried to re-run it manually via ssh session and had the same result - in the error, it shows Invalid response from https://muc.mydomain.tld/yunohost/admin/ and a status code of 403 - I am not sure how to proceed with resolving this issue, so any assistance would be greatly appreciated.

After reading Unable to renew let´s encrypt certificate I followed @Supbol’s lead and disabled XMPP which allowed the cert to be renewed successfully, but ideally I’d like to turn XMPP back on.


Have you tried sudo yunohost domain config set mydomain.tld feature.xmpp.xmpp -v yes (changing mydomain.tld to your domain) to enable XMPP again after certficate’s renewal?

@quiwy reported in the topic you put as reference he had no more issue with cert renewal in 11.1.5, although you state being in 11.1.19.
In my case, I have left XMPP disabled so far since I encountered that issue. I have just enabled it again to check in the future whether I still happen to have cert renewal issues.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.