Cannot install apps due to crash in Catalog

,

My YunoHost server

Hardware: Old laptop or computer
YunoHost version: 11.0.9
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes

This is a brand new installation. I installed NextCloud, then HegeDoc, then Jitsi. Jitsi did not work, probably because I need to open some ports in my router.

This problem occurred after I installed Jitsi. I tried removing Jitsi again, but it didn’t help.

Description of my issue

When hitting the green “Install” button to see the software catalog, I got a friendly error prompt with this stack trace:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/moulinette/interfaces/api.py", line 460, in process
    ret = self.actionsmap.process(arguments, timeout=30, route=_route)
  File "/usr/lib/python3/dist-packages/moulinette/actionsmap.py", line 586, in process
    return func(**arguments)
  File "/usr/lib/python3/dist-packages/yunohost/app_catalog.py", line 60, in app_catalog
    subtags["title"] = _value_for_locale(subtags["title"])
TypeError: string indices must be integers

I could presumably fix this for myself by manually editing the Python code, but maybe there is a more obvious and non-hacky way of doing this.

(Should be fixed, can you try to update the app catalog (just open the ‘System update’ section of the webadmin, that refreshes the catalog)

1 Like

Hurray, it works now!

Thanks a lot :slight_smile: