Can not run postinstall and create admin account, "yunohost-api not working" but status says it's working


After my previous post, I encountered some new issues with updating yunohost in order to install my first app: Nextcloud. It needed a newer version that the one on the image. After trying so many commands I decided to go from a fresh start and flashed my sd card.

I’m on Raspberry Pi 1. Directly after image flash.

I’ve tried twice and both times, the post installation process cannot be started.

I needed to clear the old certificate from my ‘known hosts’ in order to access the server, and upon logging into the root account choose to accept the new one.

Via the web innterface, I can click: Begin → URL → password, and after hitting enter on the password setup I get “The YunoHost API is not responding. Maybe ‘yunohost-api’ is down or got restarted?” in the red log at the top and dead end there.

Via command line, it’s illegal instruction:
root@yunohost:~# yunohost tools postinstall
Main domain:
New administration password:
Confirm new administration password:
Illegal instruction

Command to restart the api service gives no output good or bad:
root@yunohost:~# service yunohost-api restart

API appears to be working though as status check:
root@yunohost:~# systemctl status yunohost-api
● yunohost-api.service - YunoHost API Server
Loaded: loaded (/lib/systemd/system/yunohost-api.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2022-05-23 11:56:28 BST; 43s ago
Main PID: 1380 (yunohost-api)
Tasks: 2 (limit: 877)
CGroup: /system.slice/yunohost-api.service
└─1380 /usr/bin/python2 /usr/bin/yunohost-api
May 23 11:56:28 yunohost systemd[1]: Started YunoHost API Server.

Where can I go from here? I don’t have many options since the initial postinstall can not create an admin account.

Thank you, I really hope I can make progress and start self hosting.

I don’t know if your password is very complex or not but to check if it’s not a problem with a character that sticks, maybe start with a simple password with just numbers and letters to eliminate this issue.

For password, I used the same pw generated in my pw manager that worked before.

I found a post at Illegal instruction pour le script de postinstall sur raspberry pi 2

sed -i ‘s/import miniupnpc/#import miniupnpc/g’ /usr/lib/moulinette/yunohost/

After running that command, post install was able to move forward and needed to select a new domain.

I think my next issue is the update process stalling out during the update of php7.3.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.