Can not install discourse

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.8.2
I have access to my server : through ssh
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

This log is now available via https://paste.yunohost.org/raw/imixijozov

Hi xianqu,

You are not lucky with installations today!

Did you have a look at the log? At the bottom it says:

2023-12-24 22:28:42,449: WARNING - ERROR:  Error installing bundler:
2023-12-24 22:28:42,451: WARNING - 	The last version of bundler (>= 0) to support your Ruby & RubyGems was 2.4.22. Try installing it with `gem install bundler -v 2.4.22`
2023-12-24 22:28:42,452: WARNING - 	bundler requires Ruby version >= 3.0.0. The current ruby version is 2.7.6.219.

Unfortunately, it seems Ruby 2.7… is the last version available via apt on Debian 11.

I think some external parts of the app have been upgraded, leading to a mismatch in version numbers for Yunohost.

There may be workarounds for the problem, but most of the available workarounds give lots of headaches down the line.

I hope another reader passes by with more hopeful news!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.