Bug à la fin des installations d'apps (SSOwat)


#1

hello tous :slight_smile:
j’ai des soucis pour installer certaines app sur #yunohost
tout se passe bien à l’install mais à la fin ça bloque sur
“La configuration de SSOwat a été générée”
pacman tourne en boucle et puis plus rien :confused:

ça me le fait pour wordpress/etherpad mypads/Searx/…

aucun souci sur d’autres app (dokuwiki/roundcube/jirafeau/ampache/…/)

une idée/piste pour régler le problème ? :slight_smile:

My YunoHost configuration
**Hardware: rpi 3
Internet access: ethernet at home
**YunoHost version:
yunohost: 2.7.10
yunohost-admin: 2.7.7
moulinette: 2.7.7
ssowat: 2.7.7


#2

étrange, je retente une install et l’app wordpress par exemple, s’affiche le temps d’un instant dans l’espace utilisateur. j’ai eu le temps de cliquer et d’arriver sur le blog :confused:
fausse joie …
je retourne sur l’espace utilisateur et plus rien
du côté admin, pacman est en boucle
La configuration de SSOwat a été générée
Vraiment curieux


#3

Au moins pour wordpress et etherpad, as-tu installé le paquet mailutils ?


#4

@Maniack_Crudelis

Mmmm non je n’ai pas installé ce paquet
Il faut l’ajouter ?

pour infos, avant de réinstaller yunohost (pour voir), je recevais le mail dans roundcube, comme quoi un wordpress est installé :confused:


#5

:thinking:

root@YunoHost:~# sudo apt install mailutils
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 mailutils : Depends: mailutils-common (= 1:2.99.98-2) but it is not going to be installed
             Depends: guile-2.0-libs but it is not going to be installed
             Depends: libfribidi0 (>= 0.19.2) but it is not going to be installed
             Depends: libgc1c2 (>= 1:7.2d) but it is not going to be installed
             Depends: libgsasl7 (>= 1.1) but it is not going to be installed
             Depends: libkyotocabinet16 (>= 1.2.76) but it is not going to be installed
             Depends: libmailutils4 (>= 1:2.99.98) but it is not going to be installed
 roundcube-ynh-deps : Depends: php-pear but it is not going to be installed
                      Depends: php-auth-sasl but it is not going to be installed
                      Depends: php-mail-mime but it is not going to be installed
                      Depends: php-patchwork-utf8 but it is not going to be installed
                      Depends: php-net-smtp but it is not going to be installed
                      Depends: php-net-socket but it is not going to be installed
                      Depends: php-crypt-gpg but it is not going to be installed
                      Depends: php-net-ldap2 but it is not going to be installed
                      Depends: php-net-ldap3 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

#6

J’ai le même problème avec Wordpress, donc si il y a une solution, je suis preneur aussi


#7

perso, je viens de réussir à installer wordpress

avec nginx -t
j’ai vu que j’avais une erreur sur une conf d’un sous-domaine
j’ai effacé les fichiers (plus besoin de ce sous domaine)
dans /etc/nginx/conf.d

sudo service nginx restart
et là wordpress s’installe

que donne nginx -t chez toi ?


#8

As-tu essayé apt-get -f install, semblerais ici que tu ais un problème de dépendances avec roundcube également.


#9

J’ai installé mailutils et mon problème a été réglé !

Merci pour l’astuce @Maniack_Crudelis


#10

j’ai fait ça ouè :wink:

J’ai installé mailutils ça l’air de mieux fonctionner dans l’ensemble, merci ! :wink:
Sans risque pour l’installation d’autres App ? impossible d’installer Jirafeau par exemple, alors que j’avais pu le faire sur l’ancienne install’ :confused:


#11

L’absence de mailutils est un problème lié aux raspi, autrement ce package est déjà installé. Aucun risque à prévoir donc.
De plus ce package sera intégré à YunoHost d’ici peu, le temps de passer par les branches de test


#12

ah ok, super ! :wink:
Merci pour la réponse @Maniack_Crudelis


#13

Merci l’installation du paquet mailutils a également résolu mon problème d’installation de Wordpress.

J’ai un raspberry pi 3 et quand j’installais Wordpress cela figeait également sur le message “La configuration de SSOwat a été générée” … et il m’était impossible de finir mon installation.

Merci @sibfactory pour le sujet et @Maniack_Crudelis pour ton astuce.