Borg is currently flagged as broken on YunoHost's application

,

Mon serveur YunoHost

Matériel: VPS acheté en ligne
Version de YunoHost: 11.0.9.15
J’ai accès à mon serveur : En SSH z-vous effectué des modificiations particulières sur votre instance ?** : non

Description du problème

Rien de bien inquiétant, mais je signale tout de même pour me rassurer.
Depuis quelques semaines (presque un mois), Diagnosis envoie ce message à propos de l’app Borg.

[WARNING] An issue was found for app Borg Backup
  - This application is currently flagged as broken on YunoHost's application catalog. This may be a temporary issue while the maintainers attempt to fix the issue. In the meantime, upgrading this app is disabled.

[WARNING] An issue was found for app Borg Local Backup
  - This application is currently flagged as broken on YunoHost's application catalog. This may be a temporary issue while the maintainers attempt to fix the issue. In the meantime, upgrading this app is disabled.

À priori les 2 sauvegardes mises en place fonctionnent, une distante et une locale.
Par contre j’ai fait la bêtise de forcer l’upgrade d’une des applications la première fois que j’ai lu ce message, cela ne semble pas avoir causé de soucis…
Y-a-t-il un soucis avec l’app Borg ??

I don’t know why it says it’s broken cause the app is level 6 and marks as “working”.

The last test is here YunoRunner for CI

We can see that the upgrade from a previous version doesn’t work on the CI, but i guess it’s because it tries to install old borg version on bullseye to test the upgrade from this old borg version…

Donc si tu vois bien dans le panneau de configuration avancé qu’il y a des archives sauvegardé et que c’est tout vert, tout va bien.

EDIT: il semble que l’app était level 4 pendant 10 jours, je ne sais pas pourquoi, mais le message de diagnostique devrait bientôt disparaître du coup.

Oui tout va bien en fait, c’était juste pour le signaler…
je vais ignorer les messages de Diagnosis du coup…

Surtout pas de manière générale j’espère. :slight_smile:

Comme indiqué par ljf, pour ce genre de messages sur les apps, il “suffit” d’aller voir les derniers messages des tests automatiques pour comprendre ce qu’il se passe.

Merci d’avoir posé la question !

1 Like

in my system is broken (and fails install) since ynh 11 update.

Have you run the python venv migration after the ynh 11 migration ?

yes, just after the upgrade. System did not report issues at the time, but borg never worked again, even tried to reinstall from backup. I can install borg package from debian repo and read/access to saved borg backups, but I’ve lost integration with YNH, the main reason I had chosen borg_ynh package.

I’ve posted in the Borg thread but nobody could help me with this issue, so I’ve changed to restic. Yes, it seems to be a python problem in my system. Unfourtunatly I’m just enthusiastic about selfhosting, but I don’t have a technical background to fully understand how borg/python work so I can not afford to experiment myself.
Many thanks for your interest :wink:

EDIT: il semble que l’app était level 4 pendant 10 jours, je ne sais pas pourquoi, mais le message de diagnostique devrait bientôt disparaître du coup.

Oui, le niveau de l’application est brièvement passé au niveau 4 début Octobre et c’est revenu au niveau 6 sur le dépôt GitHub avec la mise à jour automatique du vendredi !

Ce n’est pas encore répercuté sur le catalogue des applications de YunoHost. Je ne sais pas comment cela doit se passer mais ça ne devrait pas tarder :crossed_fingers:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.