Borg : Cannot set a distant backup with borg-ynh and borg-server-ynh

,

My YunoHost server

Hardware: Raspberry at home
YunoHost version: Up to date :slight_smile:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi,

I’m desperetly trying to install borg + borg server but I fail.
It’s frustrating because I’ve done it in the past without any issue.

So, here is what I do on my main server (the one that I would like to backup) to install the ynh-borg app :

root@box:~# yunohost app install borg
In which borg repository location do you want to backup your files ?: ssh://saveruser@saver.mydomain.fr/~/backup
Provide a strong passphrase to encrypt your backups. No blank space: 
Should Borg backup your YunoHost configuration? [yes | no] (default: yes): 
Should Borg backup emails and user home directory? [yes | no] (default: yes): 
Which apps should Borg backup ? (default: all): 
With which regular time schedule should the backups be performed? (see systemd OnCalendar format) (default: Daily): Daily

Then look, in the email “borg was installed”, there is no user specified (it’s empty) :

This is an automated message from your beloved YunoHost server. Specific information for the application borg. You should now install the "Borg Server" app on [saver.mydomain.fr]:22 and with the following credentials: User: Public key: ssh-ed2sdsqkd....sdlksmdl6A/H [root@mydomain.fr]

Do you think it’s normal ?

After that, I install borg_server on the backup server :

root@saver:~# yunohost app install borgserver
Indicate the SSH user to create: saver
Indicate the public key given by borg_ynh app: ssh-ed25519 AAAAC3N........W3uY1lI+G root@box.sucha.fr
After which delay in days should we alert if there are no changes on repo ? (default: 1): 
Emails to whom send alerts ? (default: root): 
Indicate the storage quota: 270GB
Info: Installing borgserver...
Info: [+++.................] > Installing dependencies...
Info: Installing/compiling borg, this may take some time...
Info: [###+++..............] > Creating SSH user used by Borg...
Info: [######++++..........] > Configuring SSH public key for remote connexion...
Info: [##########+++.......] > Avoiding to backup the backup itself...
Info: [#############+++....] > Configuring cron to monitor backup...
Info: [####################] > Installation of borgserver completed

But now end with the backup faling.
Here is an extract from the failure email report :

Remote: Debian GNU/Linux 10
Remote: Permission denied, please try again.
Remote: Permission denied, please try again.
Remote: saveruser@saver.mydomain.fr: Permission denied (publickey,password).

On the backup server, the /var/log/access.log shows :

tail /var/log/auth.log -f
Jul  2 14:28:44 saver sshd[11368]: Failed password for saveruser from 10.8.0.11 port 55604 ssh2
Jul  2 14:28:44 saver sshd[11368]: Failed password for saveruser from 10.8.0.11 port 55604 ssh2
Jul  2 14:28:44 saver sshd[11368]: Connection closed by authenticating user saveruser 10.8.0.11 port 55604 [preauth]
Jul  2 14:28:46 saver sshd[11370]: rexec line 29: Deprecated option UsePrivilegeSeparation
Jul  2 14:28:46 saver sshd[11370]: Connection from 10.8.0.11 port 55606 on 10.8.0.8 port 22
Jul  2 14:28:46 saver sshd[11370]: Failed publickey for saveruser from 10.8.0.11 port 55606 ssh2: ED25519 SHA256:bTeOe7R......vTE9O4U
Jul  2 14:28:47 saver sshd[11370]: Failed none for saveruser from 10.8.0.11 port 55606 ssh2

Where 10.8.0.11 is the IP of the main Yunohost server.

So it looks like there is an issue with the public key, but I just don’t understand.

I also tried to remove / reinstall everything, but it didn’t work.

Thanks in advance for your kind help !

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.