Better but still difficult Install on debian10 from terminal

Hi lucky big brain guys. And i wonder if i have seen your faces in Yuno videos on Yt :wink:
I have been watching many…
After second install of Debian10 & Yuno using terminal =little better but still not good.
Yuno refusing my login credentials after install.Why this is happening? Could it be that the Debian install also asking me names even before terminal Yuno curl install is putting too many infos in system? I have no idea ?

When you installed, it asked you if you want Yunohost to take over SSH configuration. If you said yes, that means root can’t login anymore. You need to login with admin.

Is that admin credits for original Debian install or admin for Yuno?

For SSH it will be for Yunohost.

Can’t remember but i think i tried every login combo in my messy notes. Maybe early to show these screens but see the answers here?

The full situation. Is this normal-weird or scary :] ?

Looks like you need to open ports on your router.

If you go to Tools > Firewall are all those ports that Diagnosis mentions open? (are the switches green?)

If they are, Yunohost is fine but you have to open those ports on your router.

The other problems like email and ipv6 are not that important right now.

Doing Yuno install instructions one step at a time. My router is a ‘Xytel’ french language which i understand, but there are more fields which i must ask.

  1. I have detected my local ip
  2. Am on the router panel to make Static vs dynamic:
    Do i fill all these fields [masque sous-reseau, ip de paserelle]or just the ‘Adresse ip’ ?

My French is rusty from high school, but don’t touch the WAN page. That is your router’s connection to the outside internet. That IP you are changing is your router’s IP. That should probably be from DHCP from your ISP.

Look in pare-feu (firewall) page. Find out the local IP address of your yunohost machine. In the firewall page, open port 80, 443, and 22 to start. Then open the other ports that Diagnosis tells you to.

This is ‘Pare-feu’ page. It has firewall on/off & part to add exceptions, look familiar? Maybe if some frenchmen saw this in between revolutions :slight_smile:

ajouter une régler de pare-feu = add a firewall rule. You need to make rules for each port here.

192.168.x.x (ip of your yunohost machine)
source: leave blank, if it wants something write (all

What is the model of your Xytel router? I can’t find Xytel online, do you mean Zyxel?

You need to find the manual from the manufacturer and it can give you more guidance on how to create this Firewall rule.

-Router is ZyXEL EMG2926

-Tried to take a shortcut as there is a ‘UPnP’ Automatic port forwarding option on router.
Terminal ‘sudo yunohost firewall reload’ responds saying i am not allowed to login as root, incident will be reported…

-Been on xyxel forum in some far asian country & zero response…it’s been a few days.

-Read some bad comments on other forums about this router, maybe my dispair but Is there a better more standard Router i could be using, what’s your router, was it more easy?

Essai ça

1 Like

Port foreward RESOLVED. Thankyou all so far…
Wasn’t in the right panel at all. Good= NAT port foreward.

Got site on web but cannot login. Been so many days…I tried the password i had written down, i think so, maybe a install quark or just a bad password?
Anyway i can recuperate it from host file system ?

Anyone please Know how to re-cup login password? Am using Yuno dns.

Can you ssh?

Ok nice surprise ! Hi there.
To be clear its the login of the yunohost dns adress ——
Checked Ipv6 & Ipv4 ping is good.
Don’t know much about ssh yet but i just tried accessing:
sudo yunohost tools adminpw
and got a:
not allowed to run sudo on user. This incident will be reported.

If the ssh is the way i’m listening to u Jarod ?
Also i just Edited my previous reply maybe better detailed.

I am reading:

Host diagnostic page indicates Port22=colorGreen/good
SSH seems responsive somehow:
user@myhost:~$ ssh
Debian GNU/Linux 10…
Not sure but i tried:
admin@myhost:~$ sudo yunohost tools adminpw
New administration password: ***************
Confirm new administration password: ***************
Info: Your root password have been replaced by your admin password.
Success! The administration password was changed

Still can’t login, don’t know after all this. it’s 2 days i’ve been busting my chops on this. Do i need to re-install to & get a password?

MAYBE if do next install step ’ Install a Let’s Encrypt certificate’

root@myhost:~# yunohost domain cert-status
Warning: ‘yunohost domain cert-status’ is deprecated and will be removed in the future
Warning: ‘yunohost domain cert-status’ is deprecated and will be removed in the future
CA_type: Self-signed
summary: WARNING
validity: 3646
root@myhost:~# yunohost domain cert-install
Warning: ‘yunohost domain cert-install’ is deprecated and will be removed in the future
Warning: ‘yunohost domain cert-install’ is deprecated and will be removed in the future
Info: Now attempting install of certificate for domain!
Info: Parsing account key…
Info: Parsing CSR…
Info: Found domains:,
Info: Getting directory…
Info: Directory found!
Info: Registering account…
Info: Registered!
Info: Creating new order…
Info: Order created!
Info: Verifying
Info: verified!
Info: Verifying
Info: verified!
Info: Signing certificate…
Info: Certificate signed!
Success! Configuration updated for ‘nginx’
Success! Let’s Encrypt certificate now installed for the domain ‘

Still NO login so tried another Certificate install using admin sudo & got a line of never ending loop of y’s

To be clear

This thread has been anything but clear. Please use the support template provided next time. We probably would’ve figured out the problem by now but it’s not very clear what’s going on.

Also please do not send private messages to members of the forum asking us to solve your problems. We all have jobs and lives outside of this forum. This is a volunteer run place, so please respect the people trying to help you.

Back to your problem…

It sounds like you can’t login to ssh with admin? But it looks like you have access to the machine via keyboard (again I’m guessing, you didn’t give us this information at the beginning)

Try this:

ssh -v

The -v will make ssh display verbose information while trying to login, this could give us more information about what is happening.

Do i need to re-install to & get a password?

And yes, the ultimate solution might be that you need to reinstall. Self-hosting has a steep learning curve, but one way to learn is to break things, then learn how to un-break them.

got a line of never ending loop of y’s

Please use the ‘preformatted text’ box to actually paste the error messages you get, instead of just describing them.