Basic Wordpress setup

I might be making a couple of complete noob mistakes but please can anyone provide any help with:

  1. Is it possible to make my Wordpress blog the top level of a domain rather than with a ‘/blog’ path tagged onto the end?
  2. Is there a default username and password for accessing Wordpress admin panel? I set it up with a yunohost user but that user account’s details do not work when trying to log into Wordpress.

Thank you.

Edit: OK, got round the password issue by installing an email app and getting Wordpress to send a password reset link.


  1. It’s possible : Put only / instead /blog in the path box to install wordpress on the top level. But it will be not possible to install other apps in this domain.
  2. It looks there is a bug with the Wordpress app. You are not the first who say there is a problem with the password on Wordpress. Reset it is the right way :wink:

Sorry for my poor english.

Thanks for the reply. Didn’t even think to try a simple ‘/’ - assumed it wasn’t possible after it would not let me leave the field blank.

I may have found another bug with the Wordpress app. If you change the path to ‘/’ it still redirects to ‘/blog’ when accessing the domain resulting in a ‘Page not found’ error.

If you are comfortable with the notions of FTP and databases, I advise you to install a Custom Webapp and put it yourself Wordpress.
In addition, it will be much easier to manage your files and make changes.

I did it 2 days ago and it works perfectly :wink:

If you change it manually or if you install it again with the proper address ?



Can you show the nginx configuration file for the wordpress? It should be there in /etc/nginx/conf.d/yourdomian.tld.d/wordpress.conf.

#–MULTISITE–if (!-e $request_filename) {
#–MULTISITE–rewrite /wp-admin$ $scheme://$host$uri/ permanent;
#–MULTISITE–rewrite ^/(/[^/]+)?(/wp-.) /$2 last;
#–MULTISITE–rewrite ^/(/[^/]+)?(/.
.php)$ /$2 last;

location / {
alias /var/www/wordpress/;
index index.php;
if (!-e $request_filename)
rewrite ^(.+)$ //index.php?q=$1 last;
if ($scheme = http) {
rewrite ^ https://$server_name$request_uri? permanent;
client_max_body_size 30m;
location ~ [^/].php(/|$) {
fastcgi_split_path_info ^(.+?.php)(/.*)$;
fastcgi_pass unix:/var/run/php5-fpm-wordpress.sock;
fastcgi_index index.php;
include fastcgi_params;
fastcgi_param REMOTE_USER $remote_user;
fastcgi_param PATH_INFO $fastcgi_path_info;
fastcgi_param SCRIPT_FILENAME $request_filename;

Include SSOWAT user panel.

#include conf.d/;


All looks good. Clear your browsers cache.

Done and issues persists - even tried opening the page in a different browser and asking a friend to check from his PC, still get redirected to /blog instead.

Can you show /etc/ssowat/conf.json.persistent ?

“additional_headers”: {
“Auth-User”: “uid”,
“Email”: “mail”,
“Name”: “cn”,
“Remote-User”: “uid”
“domains”: [”,”,”,”,”,
“portal_domain”: “”,
“portal_path”: “/yunohost/sso/”,
“protected_regex”: [],
“protected_urls”: [],
“redirected_regex”: {[\/]?$”: “
“redirected_urls”: {},
“skipped_regex”: [
“skipped_urls”: [”,”,”,”,”,”,”,”,”,”,”,”,
“unprotected_regex”: [],
“unprotected_urls”: [”,
“users”: {
“abers”: {”: “Nextcloud”,”: “WordPress”,”: “Rainloop”

Its conf.json file you showed. There is another file conf.json.persistent. Please show that one.

Apologies - didn’t notice the last suffix there. I think we have found the issue:

“redirected_urls”: {
“mydomain.comt/”: “

Please remove the line "mydomain.comt/": ""
Then regenerate the SSOwat configuration by this command yunohost app ssowatconf

1 Like

Fixed! Thanks for all the help.