Authentication failures + services fail

My YunoHost server

Hardware: Hetzner cloud
YunoHost version: (stable)
I have access to my server : both
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

When I run diagnosis I get:

There’s been a suspiciously high number of authentication failures recently. You may want to make sure that fail2ban is running and is correctly configured, or use a custom port for SSH as explained in Security | Yunohost Documentation.

Plus some services are failing which means some apps are unreachable.

I changed the SSH port but nothing changed.

Any help is appreciated.

I just updated to (stable).
The authentication failures no longer come up in the diagnosis, but the services still fail.

Which ones? And share their logs.

Ecko, Ecko 2 and Mastodon. Where do I get logs for failed services?

PS: I found it, but nothing happens when I click on “Share logs with YunoPaste”.

Here they are:

Can anyone make any sense of this?

Aug 19 11:13:11 bundle[2161]: /var/www/mastodon__3/live/vendor/bundle/ruby/3.0.0/gems/bootsnap-1.11.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:30:in `require': cannot open shared object file: No such file or directory

Sounds like maybe libicudata is missing on the system … Can we check if such a thing exist with apt search libicudata ?

It just says:

Sorting… Done
Full Text Search… Done

So the proper lib is in fact named libicu-dev … so apt install libicu-dev should fix the issue

However, that lib should be a dependency of mastodon--3-ynh-deps but maybe you somehow forced-uninstalled one of those, and then some of mastodon’s dependencies got autoremoved … One way or another, I suspect that if you run dpkg --list | grep mastodon, nothing shows up ?

Imho the proper fix for this is to force-upgrade mastodon with yunohost app upgrade mastodon__3 --force. This will recreate the virtual dependency, reinstall libicu-dev and other things that mastodon may require.

resulted in:


rbenv: cannot rehash: /opt/rbenv/shims/.rbenv-shim exists

(soft poke @yalh76 in case you are familiar with this since you kinda created the ruby helpers if i recall correctly)

1 Like

A fresh install of Mastodon doesn’t work either.

Okay so it seems the YH upgrade somewhat broke my YH instance. Restoring Mastodon on a new YH instance worked, so I guess it wasn’t an issue with Mastodon, but with YH.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.