# Applications qui se désinstallent parce que la mise à jour bloque + nginx qui ne démarre plus / " start-pre operation timed out"

**URL:** https://forum.yunohost.org/t/applications-qui-se-desinstallent-parce-que-la-mise-a-jour-bloque-nginx-qui-ne-demarre-plus-start-pre-operation-timed-out/36447
**Category:** Support
**Tags:** french
**Created:** [April 12, 2025, 7:21pm UTC](https://forum.yunohost.org/t/applications-qui-se-desinstallent-parce-que-la-mise-a-jour-bloque-nginx-qui-ne-demarre-plus-start-pre-operation-timed-out/36447 "2025-04-12T19:21:46Z")
**Posts on this page:** 1
**Showing post:** 33

<div class="post-metadata">

### Author: ![Aleks](https://forum.yunohost.org/user_avatar/forum.yunohost.org/aleks/32/1704_2.png) [@Aleks](https://forum.yunohost.org/u/Aleks)
#### Post date: [May 4, 2025, 8:31pm UTC](https://forum.yunohost.org/t/applications-qui-se-desinstallent-parce-que-la-mise-a-jour-bloque-nginx-qui-ne-demarre-plus-start-pre-operation-timed-out/36447/33 "2025-05-04T20:31:54Z")

</div>

The issue is definitely about

```auto
Apr 11 18:40:01 artanux.be systemd[1]: Starting nginx.service - A high performance web server and a reverse proxy server...
Apr 11 18:41:31 artanux.be systemd[1]: nginx.service: start-pre operation timed out. Terminating.
Apr 11 18:41:31 artanux.be systemd[1]: nginx.service: Control process exited, code=killed, status=15/TERM

```

which i saw a few times in the past (for example [here](https://forum.yunohost.org/t/nginx-cannot-start-after-update/18623)) but unfortunately is pretty fuzzy and it’s not clear to me what could be causing this in the first place (nor apparently how you managed to solve it apparently?)

The “Start-Pre” operation is apparently, according to `systemctl cat nginx` :

```auto
ExecStartPre=/usr/sbin/nginx -t -q -g 'daemon on; master_process on;'

```

which is basically just `nginx -t` … plus the `-g` option which is a bit obscure to me

Searching on Google, [this article](https://www.plesk.com/kb/support/nginx-fails-to-start-on-plesk-server-nginx-service-start-pre-operation-timed-out-failed-with-result-timeout/) is talking about OCSP stapling but that doesn’t seem to correspond to YunoHost’s context

[This thread](https://unix.stackexchange.com/questions/671711/nginx-timeout-when-started-via-systemd-unit) is talking about `PID=/run/nginx.pid` versus `PID=/run/nginx/nginx.pid` (in the systemd conf) but I doubt this is the issue (why would your conf be different than anybody else and why was it working in the past..)

Soooo idk, maybe if the issue pops back up, I would try manually running the “StartPre” operation (`/usr/sbin/nginx -t -q -g 'daemon on; master_process on;`) to see if that command is indeed taking an unusual amount of time (more than a (few?) second)

---

_[View the full topic](https://forum.yunohost.org/t/applications-qui-se-desinstallent-parce-que-la-mise-a-jour-bloque-nginx-qui-ne-demarre-plus-start-pre-operation-timed-out/36447)._
