App_upgrade_failed - services masqués, api innacessible

Bonjour à tous,

Après un simple yunohost tools upgrade j’ai eu droit à une série de mise à jour de paquet, notamment dovecot et yunohost-api. Les paquets yunohost ont été supprimés (ex: Removing yunohost-admin (2.4.2) ... dpkg: warning: while removing yunohost-admin, directory '/usr/share/yunohost/admin' not empty so not removed Removing yunohost (2.4.2) ... Removing dovecot-antispam (2.0+20150222-1~bpo8+1).
Et - je suppose - avant l’installation d’une mise à jour, l’opération a rencontrée une erreur: Erreur : app_upgrade_failed.

J’ai eu plein d’erreur d’un script perl du type:

perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = “fr_FR.UTF-8”

Ou: Can't set locale; make sure $LC_* and $LANG are correct!

La commande locale me donne ça:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=fr_FR.UTF-8
LANGUAGE=
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

Résultat, plus d’api Yunohost, la commande yunohost ne répond plus (-bash: yunohost: command not found) et les services Yunohost sont masqués:

yunohost-firewall.service
Loaded: masked (/dev/null)
Active: inactive (dead)

yunohost-api.service
Loaded: masked (/dev/null)
Active: inactive (dead)

Bon j’ai des sauvegardes pour restaurer tout ça, mais j’aimerai essayer de réparer, histoire de comprendre ce qui a foiré / savoir le faire. :wink:
Une idée de comment réparer ça ? Merci :slight_smile:

Pour le reste, tout tourne correctement niveau application. (pas testé les courriels par exemple)

PS: je peux fournir les logs complets, en PM/après les avoir nettoyés des données persos :wink:

Salut,

c’est assez curieux comme situation, on dirait que yunohost s’est auo-désinstallé ? Je veux jeter un coup d’oeil aux logs :o

Une nouvelle mise à jour révolutionnaire :smiley: :stuck_out_tongue:
Je te passe ça par MP :wink:

Je rencontre le même problème avec un apt upgrade.
C’est ça qui a foiré, un problème de locale avec perl…

Du coup, dpkg-reconfigure locales, j’ai remis ça:

en_GB.UTF-8… done
fr_FR.ISO-8859-1… done
fr_FR.UTF-8… done

Une idée de comment réinstaller ce qui a été supprimé ? :confused:

Apres discussion en privé, j’ai ouvert un ticket sur le bugtracker : https://dev.yunohost.org/issues/687