App Uninstall breaks PHP 7.3

My YunoHost server

Hardware: Dell R720
YunoHost version: Powered by YunoHost 4.15 (stable).
I have access to my server : SSH, webadmin, direct access
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : not really. I have a RAID server.

Description of my issue

I tried to uninstall backdrop. It failed. Since then, any app that depends on PHP 7.3 also fails. Here are the logs:

it’s a lot more serious than I realized, almost none of the apps work now, including nextcloud. the error seems to be related to a directory not existing for backdrop uninstall but I don’t know how to delete a directory that doesn’t exist :frowning:

Have you tried restarting the php7.3-fpm service in webadmin-> services?

Yes,.of course! Apologies, thought those logs made it over too. Here they are : hastebin

It looks like the pool conf has not been deleted?
Can you check that it is still there with ls /etc/php/7.3/fpm/pool.d/backdrop.conf ?
If it does not return an error: rm /etc/php/7.3/fpm/pool.d/backdrop.conf and reload the service again.

1 Like

Thank you :sob: that was it!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.