An autistic approach to installing YunoHost. (Warning - lots of graphics)

I have just tried editing /etc/resolv.conf now, and tried it with /etc/resolvconf/run/resolv.conf as well, but the web interface for Yunohost is still unreachable. Do I need to do anything else after changing the nameserver, such as restarting the dnsmasq service again?

By the way, I now have my two new 32GB USB3.1 flash drives, and I’m keen to reinstall this all from scratch, whenever.

The one should be a symlink to the other; /etc/resolv.conf is actually used by the system.

I don’t recall that being necessary. Your public IP has not changed, by coincidence? Is domain resolving working now, when you ping an external domain for example?

You want to replace the uSD card anyway, no reason to postpone it. Does the RPi boot directly from USB?

Yes! It works! :tada: :heart_eyes: I have conscripted an old 8GB USB2.0 flash drive as my new “rpi-rescue” boot disk, and installed Raspbery Pi OS 11 (Bullseye) on it. It boots nicely from the USB port on the pi, without any SD-card. I’ll keep that one on hand if I get into any troubles again with booting up.

I might just take a break here for Christmas. I’m satisfied with what I’ve achieved so far. I’ll be back in the New Year, and get my setup running fully under Yunohost on the test-fmds.noho.st raspi. By about June 2022 I hope to roll out my production system on the primary fmds.noho.st raspi. Thanks for all the help so far everyone, and especially to @wbk for sticking with me through this project.

yunohohohost-meri-kirihimete

3 Likes

I have created a rollout plan for my test-fmds.noho.st installation. My plan involves a fortnightly staged rollout of each app under YunoHost, giving me time to focus on configuring and fine-tuning each app. The rollout plan is available on this calendar, but here are the essentials…

  1. debian_80px Debian base and yunohost_80px YunoHost — :dart: 16-Jan-2022

  2. netdata_80px Netdata:dart: 30-Jan-2022 — yunohost-apps_80px yunohost-forum-tags_80px

  3. pi-hole_80px Pi-Hole:dart: 13-Feb-2022 — yunohost-apps_80px yunohost-forum-tags_80px

  4. wireguard_80px WireGuard:dart: 27-Feb-2022 — yunohost-apps_80px yunohost-forum-tags_80px

  5. nextcloud_80px NextCloud:dart: 13-Mar-2022 — yunohost-apps_80px yunohost-forum-tags_80px

  6. vaultwarden_80px VaultWarden:dart: 27-Mar-2022 — yunohost-apps_80px yunohost-forum-tags_80px

  7. borg_80px BorgBackup:dart: 10-Apr-2022 — yunohost-apps_80px yunohost-forum-tags_80px

  8. firefly-iii_80px Firefly III:dart: 24-Apr-2022 — yunohost-apps_80px yunohost-forum-tags_80px

  9. grocy_80px Grocy:dart: 8-May-2022 — yunohost-apps_80px yunohost-forum-tags_80px

  10. monica_80px Monica pCRM:dart: 22-May-2022 — yunohost-apps_80px yunohost-forum-tags_80px

  11. wordpress_80px Wordpress:dart: 5-Jun-2022 — yunohost-apps_80px yunohost-forum-tags_80px

  12. webtrees_80px Webtrees:dart: 19-Jun-2022 — yunohost-apps_80px yunohost-forum-tags_80px

  13. calibre_80px Calibre-web:dart: 5-Jun-2022 — yunohost-apps_80px yunohost-forum-tags_80px

  14. owntracks_80px OwnTracks:dart: 17-Jul-2022 — yunohost-apps_80px yunohost-forum-tags_80px

  15. jellyfin_80px Jellyfin:dart: 31-Jul-2022 — yunohost-apps_80px yunohost-forum-tags_80px

I want to get Netdata installed early, so that I can keep an eye on the load on the Raspberry Pi, particularly CPU and RAM load, as I add extra apps. I may need to purchase another Raspberry Pi for this project before I finally deploy my production fmds.noho.st environment.

211230_1158_fmds-deployment-plan_test_tree-view

The apps identified in the image above, with •VPN at the end, will only be accessible from within our home LAN network, or via a secure VPN tunnel connection.

211230_1101_fmds-deployment-plan_test_github-project-board

Looks like a plan, good luck!

I have just posted a question on the prometheus_80px Prometheus Discourse forums, enquiring about how best to use their software as I roll out my project, to ascertain the load on my RasPi device. I’m still weighing up whether to use prometheus_80px Prometheus or netdata_80px Netdata for the monitoring. Any advice from the user community here?

EDIT: See also this thread by @wbk.

:heavy_check_mark: I have requested a reset of my former test-fmds.noho.st domain, as I prepare for the new install on the 32GB USB3.1 flash drive in the New Year.

I have asked a question elsewhere on the YNH forums, about which version I should install…

  • YunoHost v4.3.4.2 installfest — can begin immediately
  • YunoHost v4.4.x installfest — t.b.a
  • YunoHost v11 installfest — t.b.a

EDIT: I had a reply from @Aleks on this question, and now I’m good to go, ready to start installing v4.3.4.2 from 1-Jan-2022 (that is tomorrow, for me). I’m looking forward to it!

2 Likes

nga-mihi-o-te-tau-hou

Happy New Year! My project of installing yunohost_80px YunoHost on my raspberrypi_80px Raspberry Pi devices begins in earnest today. Don’t expect this to be a quick install though. My planned “installfest” is going to be spread throughout 2022 in two major stages: ❶ rolling out the test-fmds.noho.st machine first; then later in the year I’ll be ❷ rolling out the full fmds.noho.st device. Also during this project I will be learning more about git_80px git and github_80px GitHub, as I attempt to make my project easily replicable for future rollouts and deployments from the test to prod devices. My ultimate goal is to have two fully operational yet independent devices, both capable of running my

“Frittro’s Managed Data Store” project, but with one able to be freely modified and “hacked on” while the other remains highly available and resolute for my end users. In the future, as new software releases and updates become available, I will deploy them to the test device first, and ensure that everything is working properly there. Then, hopefully, I can deploy the required changes and updates to the prod device just using git. That is my hope, anyway. I still have a lot to learn about using git and GitHub first though, as I am more of a sysadmin/ops person than a developer, so I don’t have a huge amount of experience with git.

220101_0835_github-showing-1-commit-ahead

1 Like

:warning: Can’t boot the test raspi from the USB! — :white_check_mark: SOLVED

Oh dear, my very first step went awry. A few days ago, I tested the booting from USB on the prod raspi and it worked perfectly. When I went to do it for real on the test raspi, I just get the error screen at boot time, saying that it can’t find the sd-card. I then tried booting the test raspi from the sd-card which I had used in the prod device earlier, so that I could see the BASH history, and re-run the same commands to get the EEPROM updated on this one, the same as I did on the other one. I assume that is the problem here. Unfortunately, that didn’t seem to help this time. I’m searching for a solution now.

EDIT: I went back to the YT video where I had learned how to do this, and realised that by using the BASH history I had missed an important step which was done in the UI, not on the CLI. I hadn’t changed the Bootloader Version. I’ve done that now, and written the changes, and my test raspi now boots from the USB drive. Yay!

1 Like

:warning: Can’t boot Debian 10 (Buster) from USB on test raspi! — :white_check_mark: SOLVED

Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
done.
Gave up waiting for root file system device. Common problems:
 - Boot args (cat proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
 - Missing modules (cat proc/modules: ls /dev)
ALERT! LABEL=RASPIBOOT does not exist. Dropping to a shell!

BusyBox v1.30.1 (Debian 1:1.30.1-4) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs)

Now it seems that my raspi ROM can handle USB booting (as per above), but the specific USB flash drive which I have prepared with Debian 10 (Buster) on it won’t boot. I assume that the procedure which I followed above now also needs to be done to both of my new USB3.1 flash drives, so that they can boot as well. It seems that it isn’t enough just to update the EEPROM on the raspi device to get this working, I also need to update the individual USB flash drives as well. Derp!

EDIT: As this isn’t specifically a yunohost_80px YunoHost-related question, I have posted it on raspi-se_80px StackExchange as well.

EDIT: This turned out to be caused by a simple misunderstanding. Being that I’m using a Raspberry Pi, I needed to install Raspbian for this to work, not Debian. The point is moot anyway, as there is no easy way to install YunoHost v4.3.4.2 directly on a Raspberry Pi, so I will have to go back to installing v4.1.7.2 and upgrading.

:warning: Can’t even login on Debian 10 Buster! — :white_check_mark: SOLVED

Eek! The differences between Raspberry Pi OS and this Debian 10 Buster are huge! I can’t even login from the command line using the default username pi and password raspberry!

Finally I found out that under Debian we need to login initially as a password-less user root and then change the password straight away. I guess that is a safer way rather than having a default username and password on all raspi devices running Raspberry Pi OS.

:warning: Can’t find, nor even install, raspi-config under Debian 10 Buster! — :white_check_mark: SOLVED

Oh gosh, this is like learning everything from the start again!

“Just install YunoHost v4.3.4.2 on top of Debian 10 Buster”, they said. No problem.

It really isn’t that simple, if I’ve never used Debian 10 Buster for Raspberry Pi before. Everything is different under plain Debian, compared to Raspberry Pi OS / Raspbian.

I need to do the raspi-config step, but Debian for Raspberry Pi doesn’t include raspi-config. I’m probably going to have to edit the /etc/apt/sources.list file first, am I right?

EDIT: Even the sudo command doesn’t exist under Debian! This is so strange! :scream:

EDIT: Also, it doesn’t help that whenever I try to look something up specifically about Debian, the top answers always seem to be about Raspbian instead, and the differences I have already found between the two are huge!

EDIT: This turned out to be caused by a simple misunderstanding. Being that I’m using a Raspberry Pi, I needed to install Raspbian for this to work, not Debian. The point is moot anyway, as there is no easy way to install YunoHost v4.3.4.2 directly on a Raspberry Pi, so I will have to go back to installing v4.1.7.2 and upgrading.

I’ve been discussing this issue on the #raspberrypi channel on Libera.chat IRC…

@Tenkawa then came across to the #yunohost channel and we continued the discussion there…

My very, very, bad. I mistyped or somehow forgot you were on Raspberry. You need Raspbian 10/Buster image, not pure Debian, to be sure all the appropriate software are installed.

2 Likes

And again, cf. the Debian 11 testing thread, just keep it simple and use YunoHost’s own image and upgrade it. It’s two commands away after post-installation.

1 Like

Once I have re-done all of my plans, which currently show me as having to install Debian 10 instead of Raspbian; and my GitHub workflow currently showing me as installing v4.3.4.2 instead of v4.1.7.2; then I will do the “two commands away after post-install”. Sorry, I have been trying very hard to get this right the first time, and following all of the instructions that I receive, to the letter. This is a major project for me, and not something that is going to get completed in five minutes. A lot of careful thought and planning has gone into my project. I document everything meticulously. I am on the Autism Spectrum, and this is just how I do things. “Overthinking things” is what I do best! :stuck_out_tongue_winking_eye:

1 Like

Understood. To summarize, regarding your RPi, there are two options, by my order of preference:

  1. Use YunoHost’s out-of-date 4.1 image for Raspberry Pi, perform the post install and upgrade your system. Adds around 5 minutes to your workflow.
  2. Use Raspbian 10 image (again, sorry for suggesting pure Debian and waste your time), and use YunoHost’s installation script (with the curl ... | bash command from the documentation). Brings you directly to current 4.3.x version, but the installation script would take noticeably more time.

End result is strictly the same though. :slight_smile:

2 Likes

Thanks, this Debian / Raspbian issue has sent me down a rabbit hole, and now I need to dig my way back out. I’ll probably take another day just to re-jig all of my plans, to set me back onto my original path of installing v4.1.7.2 first, which is what I had tried previously, some 14 days ago with my initial test install of YunoHost. Unfortunately, that upgrade failed rather spectacularly, which is why I was hoping to jump straight to v4.3.4.2 without having to do an upgrade.

I have re-written my first milestone for this project. The due date remains the same.

220102_0924_milestone-1-documented-in-github